
5 Layer Basics

Both Adobe Photoshop and 

Adobe ImageReady let you isolate 

different parts of an image on layers. 

Each layer can then be edited as discrete 

artwork, allowing unlimited flexibility in 

composing and revising an image. Layer 

comps you define for combinations of 

layer settings give you easy flexibility for 

reviewing various designs.
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In this lesson, you’ll learn how to do the following:

• Organize artwork on layers.

• Create new layers.

• View and hide layers.

• Select layers.

• Remove artwork from layers. 

• Rearrange layers to change the stacking order of artwork in the image.

• Apply blending modes to layers. 

• Link layers to work on them simultaneously. 

• Apply a gradient to a layer.

• Add text and layer effects to a layer.

• Save a copy of the file with the layers flattened.

• Create layer comps with differences in visibility, position, and effects.

• Duplicate, update, and display layer comps.

This lesson will take about two hours to complete. If you want to break the lesson into 

more than one work session, there are natural break points before beginning “Creating a 

layer set and adding a layer” on page 168 and before starting “Using layer comps” on 

page 172. The lesson is designed to be done in Adobe Photoshop, but information on 

using similar functionality in Adobe ImageReady is included where appropriate.

If needed, remove the previous lesson folder from your hard drive, and copy the Lesson05 

folder onto it. As you work on this lesson, you’ll overwrite the start files. If you need to 

restore the start files, copy them from the Adobe Photoshop CS Classroom in a Book CD.

Note: Windows 2000 users need to unlock the lesson files before using them. For more infor-

mation, see “Copying the Classroom in a Book files” on page 3.
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Getting started
You’ll start the lesson by viewing an image of the finished lesson file.

1 Start Photoshop and then immediately hold down Ctrl+Alt+Shift (Windows) or 

Command+Option+Shift (Mac OS) to restore the default preferences. (See “Restoring 

default preferences” on page 4.) 

As messages appear, select Yes to confirm that you want to reset preferences, No to defer 

setting up your color monitor, and Close to close the Welcome Screen.

2 On the tool options bar, select the File Browser button, and use the Folders palette to 

navigate to and select the Lessons/Lesson05 folder on your hard disk.

3 In the thumbnails palette, select the 05End.psd file, so that it appears in the Preview 

palette in the File Browser.

4 Select the 05Start.psd file and compare it to the 05End file.

About layers
Every Photoshop file contains one or more layers. New files are generally created with a 

background layer, which contains a color or an image that shows through the transparent 

areas of subsequent layers. You can view and manipulate layers using the Layers palette.

All new layers in an image are transparent until you add text or artwork (pixel values). 

Working with layers is analogous to placing portions of a drawing on sheets of acetate: 

Individual sheets of acetate may be edited, repositioned, and deleted without affecting the 

other sheets. When the sheets are stacked, the entire composition is visible. 

Viewing information in the Layers palette

The Layers palette displays all layers with the layer names and thumbnails of the images 

on each layer. You can use the Layers palette to hide, view, reposition, delete, rename, and 

merge layers. The palette thumbnails are automatically updated as you edit the layers. 

1 In the File Browser thumbnails pane, double-click the 05Start.psd file to open it in 

Photoshop. (Do not close the File Browser yet.)

2 If the Layers palette is not visible in the work area, choose Window > Layers. 
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There are three items listed in the Layers palette for the 05Start.psd file: first Statue, then 

Doorway, and finally Background. The Background layer is highlighted, indicating that it 

is the active layer. Notice the layer thumbnails and the icons on the Background layer 

level.

Use the context menu to hide or resize the layer thumbnail. Right-click (Windows) or 

Control-click (Mac OS) an empty area of the Layers palette to open the context menu, and 

then select None, Small, Medium, or Large

3 Use the File Browser again (or choose File > Open) to open the Door.psd file in the 

Lesson05 folder. Then close the File Browser.

The Layers palette changes to display the layer information and a thumbnail for the 

Door.psd file. There is only one layer in the Door.psd image: Layer 1.

In the Layers palette for the 05Start file, you saw three icons on the Background layer: a 

lock icon at the right side of the layer name, an eye icon, and a paintbrush icon. None of 

these appeared on the other two layers. 

• The lock icon ( ) indicates that the Background layer is protected. 
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• The eye icon ( ) indicates that the layer is visible in the image window. If you click the 

eye, the image window no longer displays that layer. 

• The paintbrush icon ( ) reminds you that the layer is active; that is, that the changes 

you make will affect that layer only.

For more information, see the “About the background layer” inset, below.

About the background layer

When you create a new image with a white background or a colored background, the bottommost image in 

the Layers palette is named Background. An image can have only one background. You cannot change the 

stacking order of a background, its blending mode, or its opacity. However, you can convert a background to 

a regular layer.

When you create a new image with transparent content, the image does not have a background layer. The 

bottommost layer is not constrained like the background layer; you can move it anywhere in the Layers 

palette, and change its opacity and blending mode.

To convert a background into a layer:

1. Double-click Background in the Layers palette, or choose Layer > New > Layer From Background.

2. Set layer options as desired.

3. Click OK.

To convert a layer into a background:

1. Select a layer in the Layers palette.

2. Choose Layer > New > Background From Layer.

Note: You cannot create a background by renaming a regular layer Background—you must use the 

Background From Layer command.
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Renaming a layer and copying it to another image file

Creating a new layer can be as simple as dragging from one file into the image window of 

another file. Whether you drag from the image window of the original file or from its 

Layers palette, only the active layer is reproduced in the destination file. Before you begin, 

make sure that both the 05Start.psd and Door.psd files are open and that the Door.psd file 

is active. 

First, you will rename Layer 1 with a more descriptive name. 

1 In the Layers palette, double-click the name Layer 1, type Door, and then press Enter 

(Windows) or Return (Mac OS).

2 If necessary, drag the Door.psd and 05Start.psd image windows so that you can see at 

least part of both images. Then, select the Door.psd image so that it is the active file.

3 In the toolbox, select the Move tool ( ) and move it over the Door.psd image window.

4 Drag the door image and drop it into your 05Start.psd image window. The Door layer 

now appears in the 05Start file image window and its Layers palette.

5 Close the Door.psd file, and do not save your changes to that file.
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If you hold down Shift when you drag an image from one file into another, the dragged 

image automatically centers itself in the target image window. 

Viewing individual layers

The Layers palette shows that the 05Start file contains three layers in addition to the Door 

layer, some of which are visible and some of which are hidden. The eye icon ( ) to the far 

left of a layer name in the palette indicates that that layer is visible. You can hide or show 

a layer by clicking this icon.

1 Click the eye icon next to the Door layer to hide the door. 

2 Click again to redisplay it.

Leave the other layers at their original visibility settings, whether hidden or shown.

Selecting and removing some pixels from a layer

Notice that when you moved the door image onto the garden image in the start file, you 

also moved the white area surrounding the door. This opaque area blocks out part of the 

garden image, since the door layer sits on top of the garden background layer.

Now, you’ll use an Eraser tool to remove the white area around the door. 

1 Make sure that the Door layer is selected. (To select the layer, click the layer name in 

the Layers palette.) 

The layer is highlighted, and a paintbrush icon ( ) appears to the left of the layer name, 

both of which indicate that the layer is active.
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2 To make the opaque areas on this layer more obvious, hide all layers except the Door 

layer by holding down Alt (Windows) or Option (Mac OS) and clicking the eye icon ( ) 

for the Door layer. 

The garden image disappears, and the door appears against a checkerboard backdrop. 

The checkerboard indicates transparent areas of the active layer.

3 Select the Magic Eraser tool ( ), hidden under the Eraser tool ( ).

You can set the tolerance for the Magic Eraser tool. If the tolerance is too low, the Magic 

Eraser tool leaves some white remaining around the door. If the tolerance setting is too 

high, the Magic Eraser tool removes some of the door image.

4 In the tool options bar, set the Tolerance value either by scrubbing the Tolerance label 

or by typing 22 in the text box. 

5 Click the white area surrounding the door image in the image window. 

Notice that the checkerboard fills in where the white area had been, indicating that this 

area is now transparent also.
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6 Turn the background back on by clicking the eye-icon box next to its name. The garden 

image now shows through where the white area on the Door layer was removed.

Rearranging layers
The order in which the layers of an image are organized is called the stacking order. 

The stacking order of layers determines how the image is viewed—you can change the 

order to make certain parts of the image appear in front of or behind other layers. 

Now, you’ll rearrange layers so that the door image moves in front of another image in the 

file that is currently hidden.

1 Make the Statue and Doorway layers visible by clicking the eye-icon boxes next to their 

layer names. 

Notice that the door image is partially blocked by the image of the brick doorway.
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2 In the Layers palette, drag the Door layer up above the Doorway layer—look for a 

wider white line between the Doorway layer and the Statue layer—and then release the 

mouse button. 

The Door layer moves up one level in the stacking order, and the door image appears in 

front of the doorway image.

Changing the opacity and mode of a layer 

The door image now blocks any images that lie on layers below it. You can reduce the 

opacity of the door layer to allow other layers to show through it. You can also apply 

different blending modes to the layer, which affects how the color pixels in the door image 

blend with pixels in the layers below them. (Currently, the blending mode is Normal.)

1 With the Door layer selected, click the arrow next to the Opacity text box in the Layers 

palette, and drag the slider to 50%. Or, you can scrub the Opacity label to set the value.

The door becomes partially transparent, and you can see the layers underneath. Notice 

that the change in opacity affects only the image area of the Door layer. The statue and 

doorway images remain completely opaque.
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2 To the left of the Opacity option in the Layers palette, open the blending modes pop-up 

menu, and select Luminosity. (You may need to scroll down to find it.)

3 Readjust the Opacity value, changing it to 90%.

4 Choose File > Save to save your work. 

You’ll do more work with blending modes in later lessons. For an explanation of the key 

terms, see “Blending an image with the background” on page 249. 

Linking layers

Sometimes an efficient way to work with layers is to link two or more related layers. By 

linking layers together, you can move and transform them simultaneously, thereby 

maintaining their alignment to each other.

You’ll now link the Door and Doorway layers, and then move and transform them as 

a unit. 

1 Select the Move tool ( ), and drag the door to the left so that the left edge of the door 

aligns with the right side of the doorway arch.

Peachpit Press/Scott Design



LESSON 5156
Layer Basics

2 Locate the Doorway layer in the Layers palette. Then, without selecting that layer, click 

the small box next to the eye icon for that layer. 

A link icon ( ) appears in the box, indicating that the Doorway layer is linked to the 

Door layer. The active (selected) layer does not display a link icon when you create linked 

layers.

3 Still using the Move tool, drag the doorway to the left side of the image window so that 

the bricks touch the left margin of the image. The door and doorway images move 

together. 

Now, you’ll simultaneously resize both linked layers. 

4 Select the Doorway layer in the Layers palette, and choose Edit > Free Transform. A 

transformation bounding box appears around the images in the linked layers. 
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5 Hold down Shift and drag the handle in the right bottom corner box down, to scale the 

door and doorway to a slightly larger size. (You may need to drag down the bottom right 

corner of the image window to enlarge it enough to see the complete transformation 

bounding box.)

6 If necessary, position the pointer inside the bounding box, and drag to reposition the 

door and doorway images.

7 Press Enter (Windows) or Return (Mac OS) to apply the transformation changes.

8 Choose File > Save.

Adding a gradient layer

Next, you’ll create a new layer with no artwork on it. (Adding empty layers to a file is 

comparable to adding blank sheets of acetate to a stack of images.) You’ll use this layer to 

add a semi-transparent gradient effect that influences the layers stacked below it.

In ImageReady, which does not have a Gradient tool, you can apply a Gradient/Pattern 

layer style from the Layers palette. You’ll get some experience applying layer styles in 

Photoshop later in this lesson; see “Applying a layer style” on page 162.

1 In the Layers palette, select the Background layer to make it active, and then click the 

New Layer button ( ) at the bottom of the Layers palette. 
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A new layer, named Layer 1, appears between the Background and the Doorway layer.

Note: You can also create a new layer by choosing New Layer on the Layers palette menu or 

Layers > New > Layer on the Photoshop menu bar.

2 Double-click the name Layer 1, type Gradient, and press Enter (Windows) or Return 

(Mac OS) to rename the layer. 

3 In the toolbox, select the Gradient tool ( ).

4 In the tool options bar, make sure that the Linear Gradient button ( ) is selected, and 

then click the small arrow to expand the gradient picker. 

5 Select the Foreground To Transparent swatch, and then click anywhere outside the 

gradient picker to close it. 

You can list the gradient options by name rather than by sample. Just click the palette 

menu button ( ) on the gradient picker and select either Small List or Large List. Or, you can 

let the pointer hover over a thumbnail until a tooltip appears, showing the gradient name.
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6 Click the Swatches palette tab to bring it to the front of its palette group, and select any 

shade of purple that appeals to you.

7 With the Gradient layer active in the Layers palette, drag the Gradient tool from the 

right margin of the image to the left margin. (You can hold down Shift as you drag to 

constrain the gradient horizontally.)

The gradient extends over the width of the layer, starting with purple on the right and 

gradually blending to transparent on the left. The gradient partially obscures the garden 

image—the layer below the gradient layer. You’ll lighten the effect by changing the 

Gradient layer’s opacity so that the garden is only veiled by the gradient.
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8 In the Layers palette, change the Opacity for the Gradient layer to 60%. The full garden 

shows through the gradient.

Note: In ImageReady, the gradient attributes appear as an effect, nested under the layer to 

which you applied it as a layer style. A gradient is still visible in the ImageReady image 

window.

Adding text

Now, you’re ready to create and customize some type. You’ll create text with the Type tool, 

which places the text on its own type layer. You’ll then edit the text and apply a special 

effect to that layer. (ImageReady also has features for creating and manipulating type, but 

it uses a palette to display type options, rather than a dialog box.)

1 In the Layers palette, click the Statue layer to make it active.

2 Set the foreground color to black by clicking the small Default Foreground And 

Background Color box ( ) near the swatches in the toolbox. 

Note: If you decide to change a text color later, you can do this by selecting the text with the 

Type tool and using the color swatch in the tool options bar.
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3 In the toolbox, select the Type tool ( ). Then, in the tool options bar, select the 

following options for the Type tool:

• Select a font from the Font pop-up menu (we used Adobe Garamond).

• Select a font style (we used Regular).

• Enter a large point size in the Size text box (we used 60 point). 

• Select Crisp from the Anti-Aliasing pop-up menu ( ).

• Select the Center Text ( ) alignment option.

4 Click somewhere in the upper middle area of the image window. 

Notice that the Layers palette now includes a layer named Layer 1 with a “T” thumbnail 

icon, indicating that it is a type layer.

5 Type Jardin, press Enter or Return, and then type 2000. 

The text appears in the upper left area of the image where you clicked. This appears in the 

Layers palette as Layer 1, but the layer name will automatically change to “Jardin 2000” as 

soon as you select another layer or another tool.You’ll see that next when you reposition 

the text in the image.
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6 Select the Move tool ( ), and drag the “Jardin 2000” text to center it under the arch of 

the doorway. The text may be a little difficult to read against the dark shrubbery in the 

background, but you’ll make adjustments for that shortly.

Notice that the layer name in the Layers palette is now Jardin 2000 instead of Layer 1.

Applying a layer style

You can enhance a layer by adding a shadow, glow, bevel, emboss, or other special effect 

from a collection of automated and editable layer styles. These styles are easy to apply and 

link directly to the layer you specify.

Photoshop Layer Style dialog box

Like layers, individual layer styles can be hidden by clicking eye icons ( ) in the Layers 

palette. You can apply a copy of a layer style to a different layer by dragging the effect onto 

the destination layer.

Now, you’ll make the text stand out by adding a glowing, yellow stroke around the type, 

and filling the type with a pattern. 

1 With the Jardin 2000 type layer still active, choose Layer > Layer Style > Outer Glow. 

(There may be a slight pause as the Layer Style dialog box opens.)
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You can also open the Layer Style dialog box by clicking the Add A Layer Style button ( ) 

at the bottom of the Layers palette and then choosing a layer style, such as Outer Glow, in the 

pop-up menu.

2 In the Layer Style dialog box, make sure that the Preview option is selected, and then 

move the dialog box aside as needed so that you can see the Jardin 2000 text in the image 

window. 

3 In the Elements area of the dialog box, enter 10 for Spread and 10 for Size in pixels.

4 In the left pane of the Layer Style dialog box, select the Stroke check box, and notice 

that the right pane of the dialog box still shows the options for the Outer Glow effect. 

Click the name Stroke to change the display so that the Stroke layer style options appear 

on the right side of the dialog box, and then select the following options:

• In the Structure area, enter 1 for Size to create a 1-pixel-wide stroke. 

• Under Fill Type, click the Color swatch to open the color picker. Then, choose a yellow 

color (we used R=255, G=255, and B=0). Click OK to close the color picker but leave the 

Layer Style dialog box open.
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5 On the left pane of the dialog box, click the name Pattern Overlay. Notice that by 

clicking the name, you automatically select the Pattern Overlay check box and change the 

available options on the right side of the dialog box. Select the following options:

• Click the arrow beside the pattern thumbnail to open a pop-up display of available 

patterns, and select Wood. Click a blank area of the dialog box to close the pop-up.

You can identify the Wood pattern thumbnail by waiting for a tooltip to appear or by 

choosing Small List or Large List on the palette list for the pattern picker.

• In the Scale option, enter 200%.

6 Examine the Jardin 2000 text in the image window. Then click OK to accept all the 

settings and close the Layer Style dialog box.

7 If necessary, scroll or resize the Layers palette so that you can see the changes in the 

palette listings. 

Now, there are four rows of information nested under the Jardin 2000 text layer. The first 

of these rows identifies them as Effects. The other three rows are named by the three styles 

that you applied to the layer: Outer Glow, Pattern Overlay, and Stroke. There is also an 

icon for layer styles ( ) next to each of the three style names. You can turn off an 

individual effect by clicking its eye icon ( ) to make it disappear. Clicking this visibility 

box again restores both the eye icon and the effect. You can hide all three layer styles by 

clicking to remove the Effects eye icon. Before you continue, make sure that eye icons 

appear for all four items nested under the Jardin 2000 layer.
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To hide the layer styles listings, click the arrow by the layer styles icon ( ) on the right side 

of the Jardin 2000 layer to collapse the Effects list.

Editing text
Layer effects are automatically applied to changes you make to a layer. You can edit the 

text and watch how the layer effect tracks the change.

1 In the Layers palette, select the Jardin 2000 text layer, if it is not already selected.

2 In the toolbox, select the Type tool ( ) but do not click in the image window yet.

3 In the tool options bar, change the Font Size option from 60 pts to 72 pts. 

Although you didn’t select the text by dragging the Type tool (as you would have to do in 

a word-processing program), all the text on the layer now appears in 72-point type. 

4 Using the Type tool, select the last zero in “2000.” 

5 Type 4 so that the text block now reads “Jardin 2004.”

Notice that the text formatting and layer styles remain applied to all the text.

6 Do one of the following to commit your typing changes on the text layer:
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• On the tool options bar, click the Commit Any Current Edits button ( ).

• Select another layer or tool.

Note: You cannot commit type by pressing Enter or Return because this merely applies a 

carriage return, creating a new line for typing.

7 Choose File > Save.

One of the other interesting things you can do in Photoshop CS is to place text on a path. 

The words or numbers can radiate out from a circle or follow a squiggly line, for example. For 

more information, see Photoshop Help.

Flattening and saving files
When you finish editing all the layers in your image, you can merge or flatten layers to 

shrink the file size. Flattening reduces all the layers into a single background. However, 

you shouldn’t flatten an image until you are certain that you’re satisfied with all your 

design decisions. Rather than flattening your original .psd files, it’s a good idea to save a 

copy of the file with its layers intact, in case you need to edit a layer later.

To appreciate what flattening does, notice the two numbers for the file size in the bar at 

the bottom of the application window (Windows) or image window (Mac OS).

The first number represents what the file size would be if you flattened the image. The 

second number represents the file size without flattening. In the lesson file, the flattened 

file would be about 900K but the current file is much larger—about 4 or 5 MB—so 

flattening is well worth doing in this case.

1 If the Type tool ( ) is currently selected in the toolbox, select any other tool, to be sure 

that you’re no longer in type-editing mode. Choose File > Save (if it is available), to be 

sure that all your changes have been saved in the file.

2 Choose Image > Duplicate.

3 In the Duplicate Image dialog box, type 05Flat.psd to name the file and click OK.
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4 Close the 05Start.psd file, but leave the 05Flat.psd file open.

5 On the Layers palette menu, choose Flatten Image. 

6 Choose File > Save. Even though you selected Save rather than Save As, the Save As 

dialog box appears.

7 Make sure that the location is set to the Lessons/Lesson05 folder, and then click Save to 

accept the default settings and save the flattened file.

You have saved two versions of the file: a one-layered flattened copy and the original file, 

in which all the layers remain intact. You will continue to work in the flattened file and 

add layers above the flattened Background layer. You’ll use the original version again later 

in this lesson.

If you want to flatten only some of the layers in a file, you can click the eye icons to hide the 

layers you don’t want to flatten, and then choose Merge Visible on the Layers palette menu.
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Creating a layer set and adding a layer
You can nest layers within the Layers palette. This makes it easier to manage your work 

and minimizes the clutter when you work on large, complex files.

1 In the Layers palette menu, choose New Layer Set. 

2 In the New Layer Set dialog box, type Conf Info, and click OK.

In the Layers palette, a Conf Info folder appears above the Background layer. You’ll use 

this layer set to hold layers that display information about the Jardin 2004 conference.

Adding type layers to a flattened background

You’re now going to work on two text layers that will have identical information but in 

different languages. 

1 In the toolbox, select the Type tool ( ).

2 In the tool options bar, set the following type specifications:

• For Font family, select Adobe Garamond (or another serif font).

• For Font Style, select Italic.

• For Font Size, enter 24 pts.

• Click the color swatch to open the color picker and select the same yellow color you 

used for Outer Glow earlier in this lesson (R=255, G=255, B=0); then click OK to close 

the color picker.

• Make sure that the Crisp option and the Center Text icon ( ) are selected.

3 Make sure that the Conf Info layer set is selected in the Layers palette. Then, click the 

Type tool ( ) in the upper right area of the image window and type Mai 18 (the date in 

the French language), press Enter or Return to create a line break, and type Montreal.
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4 In the tool options bar, select the Commit Any Current Edits button ( ).

In the Layers palette, a new type layer appears, nested under the Conf Info layer set. The 

name of the layer in the Layers palette is now “Mai 18.”

5 Select the Move tool ( ) and drag the text to the upper right side of the image so that 

the design is balanced and the text is readable against the foliage behind it.

6 Select the “Mai 18” layer in the Layers palette and drag it to the New Layer button at 

the bottom of the palette. When you release the mouse button, a duplicate of the text layer 

appears, also nested in the Conf Info layer set.

If you decide later that you want to reposition the two text layers, you can select the Conf 

Info layer set in the Layers palette, and then use the Move tool to drag both layers, as if they 

were linked. 

You now have an identically formatted and positioned text layer that you can edit to create 

an alternative version.
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Creating alternate text and designating dictionaries

Photoshop includes a versatile spelling checker that can selectively reference dictionaries 

for various languages. You can designate entire text layers or individual words to be 

checked in different dictionaries. When you run the spelling checker, Photoshop 

automatically compares each word to the appropriate dictionary.

1 In the Layers palette, select the upper “Mai 18” layer, if it is not still selected.

2 Choose Window > Character to open the Character palette. 

3 On the dictionary pop-up menu in the lower left corner of the Character palette, select 

Canadian French.

4 One after another, select the “Mai 18” layers in the Layers palette and verify that the 

Character palette indicates an English dictionary for the lower layer and a Canadian 

French dictionary for the upper layer.

5 Choose File > Save.

Peachpit Press/Scott Design



171ADOBE PHOTOSHOP CS
Classroom in a Book

Using the multilingual spelling checker

Now that you’ve designated the dictionaries that Photoshop will use for different text 

within your file, you’re ready to review the text for spelling errors.

1 In the Layers palette, make sure that the eye icons ( ) for the “Mai 18” layers so that 

both text layers appear in the image window. Since these are right on top of each other, 

you can’t see any difference in the image window. 

2 Choose Edit > Check Spelling. The Check Spelling dialog box appears, indicating that 

the word Montreal is misspelled in the Canadian French version because the word lacks 

an accent over the letter e. 

3 Click the Change button to accept the suggested replacement, Montréal. 

The text in the image changes, and the display in the dialog box also changes, now 

indicating that the word Mai is not in the English: USA dictionary. Notice that the Change 

To option is (probably) Mail—not the word you want.

4 Scroll down the Suggestions list if necessary, and select the word May. Now, May 

appears in the Change To option. Then, click Change.

Instead of scrolling and selecting, you can type May directly into the Change To option. 

5 If a message appears indicating that the spell check is complete, click OK. 

6 Alternately click the eye icons off and on for the two Conf Info text layers to see the two 

versions of the text. 
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7 Choose File > Save to save the image, which now has the original flattened layer plus 

two unflattened text layers. Leave the 05Flat.psd file open for the next procedure.

Notice the change in file size in the Status bar. Although your file size has grown slightly, 

it is still not nearly as large as the completely unflattened project would be.

Leave the 05Flat.psd file open, because you’ll need it in an upcoming task.

Using layer comps
Layer comps is a new feature in Photoshop CS that provides one-click flexibility in 

switching back and forth between different views of a multilayered image file. A layer 

comp is simply a definition of the settings in the Layers palette. Once you’ve defined one 

layer comp, you can change as many settings as you please in the Layers palette and then 

create another layer comp to preserve that configuration of layer properties. Then, by 

switching from one layer comp to another, you can quickly review the two designs. The 

beauty of layer comps becomes apparent when you want to demonstrate a number of 

possible design arrangements to a client, for example. 

In this section of the lesson, you’ll continue working with your gardening conference 

project, but you’ll use the version you saved earlier, not the flattened version. You’ll create 

different comps for each of the two languages used. You’ll also try out different visibility 

and layer styles, and then record layer comps for these possibilities. When you finish 

creating the layer comps, you can then review all the possible arrangements you’ve 

defined without having to select and deselect eye icons or change settings in the Layers 

palette. The layer comps are saved as part of the file, so they are not lost when you quit 

Photoshop.
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Preparing a full-layered version of the Photoshop file

You won’t work in the flattened version of your work for these tasks. Instead, you’ll use 

the unflattened version of the 05Start.psd image that you saved earlier (see “Flattening 

and saving files” on page 166), because this gives you full access to all of the original layers 

that went into the composition. However, you will update the 05Start.psd file by copying 

the two text layers from the 05Flat.psd file.

1 Choose File > Open Recent > 05Start.psd. 

2 Choose File > Open Recent > 05Flat.psd, if this file is not already open.

3 Arrange the image windows for the two files so that you can see at least part of both 

windows, and then select the image window for the flattened version to bring it forward 

and make it active (or choose Window > 05Flat.psd).
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4 In the Layers palette, select the Conf Info layer set. Hold down Shift and drag it from 

the Layers palette to the 05Start.psd image window.

5 Close the 05Flat.psd file, but leave the 05Start.psd open.

6 Select the Move tool ( ), and drag the text as needed to reposition it.

Because the Conf Info layer set is selected in the Layers palette, the two versions of the text 

move together when you drag. Holding down the Shift key as you drag places the layers 

in the same location they had in the original image window.

Create new layer comps based on layer visibility

The first two layer comps you create will simply show one or the other of the two language 

versions (French or English) for the conference information. This reduces the effort 

required to switch back and forth between the two versions from two clicks (resetting the 

eye icons) to one click (selecting a layer comp).

1 Open the Layer Comps palette by clicking its tab in the palette well. 
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2 Drag the Layer Comps palette tab from the palette well to any convenient location on 

your screen, placing it so that you can see it, the entire image window, and the Layers 

palette as you work. (You can close the Navigator, Color, History, and Character palette 

groups to reduce clutter.)

3 Move and resize the Layers palette as needed so that you can see all levels with all items 

fully expanded.

4 In the Layers palette, click the eye icon ( ) for the “Mai 18” text layer to hide it. In the 

image window, make sure that the “May 18” text layer is visible.

5 In the Layers Comp palette, click the Create New Layer Comp button ( ) at the 

bottom of the palette.
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6 In the New Layer Comp dialog box, type English in the Name option and select all 

three check boxes under Apply To Layers: Visibility, Position, and Appearance. Then click 

OK.

7 Using the eye icons in the Layers palette, make the “Mai 18” layer visible and hide the 

“May 18” text layer.

8 Repeat Steps 5 and 6, but this time type French instead of English as the name for the 

new layer comp.

Although the switch between the French and English versions of the image involves only 

changes in visibility—that is, the state of the eye icons in the Layers palette—you’ll be 

making other types of changes later in this section. That’s why you selected all three check 

boxes under Apply To Layers when you defined these two layer comps. 
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What would happen if you had selected only the Visibility option? You’d need to 

backtrack later to select the other two options, reset the original layer conditions, and 

then update these layer comps—a lot of extra work that you can avoid by selecting all 

three options now. 

Using layer comps to view document variations

Here’s the fun part about layer comps: switching back and forth. Although your two layer 

states differ only in the visibility of two layers, with a little imagination you can appreciate 

how much of a time-saver this would be for more complex variations.

1 If the Apply Layer Comp icon ( ) does not already appear on the French layer comp, 

click the box to set it there now. The image window shows the “Mai 18” text layer and and 

hides the “May 18” text layer.

2 Click the box for the English layer comp. The Apply Layer Comp icon appears beside 

the English layer comp instead of by the French layer comp, and the visibility of the “Mai 

18” and “May 18” text layers reverses.

3 In the Layers palette, click the “Jardin 2004” text layer eye icon to hide that layer.

In the Layer Comps palette, notice that the Apply Layer Comp icon now appears on the 

Last Document State level, indicating that the current layer settings are no longer based 

on a defined layer comp.

4 In the Layer Comps palette, click the box next to the French layer comp, so that the 

Apply Layer Comp icon appears there. 

The image returns to its state when you defined this layer comp—with the “Jardin” and 

“Mai 18” text layers visible.

5 Click the box for Last Document State.

Now, the image appears as it did after Step 3, with the “Jardin” text layer hidden and the 

conference information in English. 
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Duplicating and editing layer comps

Like other items that appear on various palette lists in Photoshop, you can drag layer 

comps to icons at the bottom of the palette and use the Layer Comps palette menu to edit 

them. You do not need to set the Apply Layer Comp icon for a layer comp in order to 

duplicate, delete, or edit its options.

1 In the Layer Comps palette, click the box for the English layer comp to apply it to the 

image. 

2 Drag the English layer comp to the Create New Layer Comp icon in the bottom of the 

Layer Comps palette. 

3 Double-click the name of the new layer comp (“English copy”) to make it active and 

type English No Door.

4 In the Layers palette, click the eye icon ( ) to make the Door layer invisible. 

In the Layers Comp palette, the Apply Layer Comp icon ( ) now appears next to the Last 

Document State layer comp, but the English No Door layer comp is still selected.
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5 Click the Update Layer Comp button ( ) to update the English No Door layer comp. 

The Apply Layer Comp icon is back next to the English No Door layer comp and the Door 

layer is still hidden.

6 One by one, click the boxes in the Layer Comps palette to place the Apply Layer Comp 

icon beside each of the three defined layer comps. As you switch from one layer comp to 

the next, examine the results in the image window.

Creating layer comps for position changes

Now that you’ve seen how layer comps preserve various visibility settings, it’s not much 

of a stretch to imagine how this could apply to different layer locations in the image 

window. This task gives you experience working with position changes and layer comps.

1 In the Layers Comp palette, click the box for the English layer comp (not the English 

No Door layer comp) to set the Apply Layer Comp icon.

2 Drag the English layer comp into the Create New Layer Comp icon, and then double-

click and type English Moved to rename the layer comp copy. 

3 In the Layers palette, select the “May 18” text layer, and then select the Move tool ( ) 

in the toolbox.
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4 In the image window, drag the “May 18” text layer so that it centers under the “Jardin” 

text layer.

5 Click the Update Layer Comp button ( ).

6 Review the results by clicking to set the Apply Layer Comp icon first in the English layer 

comp and then in the English Moved layer comp.

Creating layer comps for style changes

You’ve already had practice with two of the three categories you selected under Apply To 

Layer Comps when you defined each of your layer comps: Visibility and Position. Next, 

you’ll work with changes to the third category: Appearance. Appearance includes changes 

in opacity as well as layer effects and layer styles. In this task, you’ll define a layer comp 

that has layer-style settings that differ from the other layer comps that you’ve created.

1 In the Layer Comps palette, click the box next to the English Moved layer comp to set 

the Apply Layer Comp icon.
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2 In the Layers palette, expand the “Jardin 2004” layer styles and click the eye icon to turn 

off the Outer Glow effect.

3 In the Layer Comps palette, click the Create New Layer Comp button ( ). 

4 In the New Layer Comp dialog box, type English Moved No Glow. Make sure that all 

three Apply To Layers options are selected (checked), or select them now, before you click 

OK. 

Leave the English Moved No Glow layer comp selected in the Layer Comps palette.

Reviewing layer comps

You’ve already switched from one layer-comp view to the next by resetting the Apply 

Layer Comp icon. (See “Using layer comps to view document variations” on page 177.) 

Now, you’ll try another simple way to cycle through the entire set of layer comps.

1 Click to set the Apply Layer Comp icon for the defined layer comp at the top of the 

Layer Comps palette list.
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2 Click the right-pointing arrow ( )in the bottom of the Layer Comps palette. The 

Apply Layer Comp icon moves to the second layer comp on the list and the image window 

changes to show the layer settings for that layer comp

3 Click the left-pointing arrow ( ). The Apply Layer Comp icon moves back to the top 

layer comp on the list.

4 Click the right-pointing arrow repeatedly to review the five variations you’ve created 

so far.

5 Choose File > Save.

Imagine how much time it would take to show someone these different layer arrange-

ments if you had to drag layers into position and select or deselect eye icons. Layer comps 

can be an especially valuable feature when the design is in flux or when you need to create 

multiple versions of the same image file.

Congratulations! Your work on the garden image is now complete. This lesson only 

begins to explore the vast possibilities and the flexibility you gain when you master the art 

of using Photoshop layers and layer comps. You’ll get more experience and try out 

different techniques for layers in almost every chapter as you progress forward in the 

book. You’ll also use layer comps in ImageReady, to streamline the animation process.
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Review questions
1 What is the advantage of using layers? 

2 When you create a new layer or layer set, where does it appear in the Layers palette 

stack?

3 How can you make artwork on one layer appear in front of artwork on another layer?

4 How can you manipulate multiple layers simultaneously?

5 When you’ve completed your artwork, what can you do to minimize the file size 

without changing the quality or dimensions? 

6 How do you check spelling in more than one language?

7 What is the purpose of layer comps and how are they useful?

Review answers
1 Layers enable you to move and edit different parts of an image as discrete objects. You 

can also hide individual layers as you work on other layers by clicking to remove the eye 

icons ( ) for the layers you don’t need to see.

2 The new layer or layer set always appears immediately above the active layer. 

3 You can make artwork on one layer appear in front of artwork on another layer by 

dragging layers up or down the stacking order in the Layers palette, or by using the 

Layer > Arrange > commands: Bring to Front, Bring Forward, Send to Back, and Send 

Backward. Remember that you cannot change the layer position of a Background layer.

4 You can link the layers by first selecting one of the layers in the Layers palette. Then you 

click the box to the left of the Layer name of the layer to which you want to link it. Once 

linked, both layers can be moved, rotated, and resized together.

5 You can flatten the image, which merges all the layers onto a single background. 

6 You designate the language dictionaries in the Character palette. You can set different 

language dictionaries to check different parts of the text in an image file, either by layer 

or by individual words: 

• To designate a dictionary for an entire layer, first select that type layer in the Layers 

palette, and then select the Type tool ( ) in the toolbox. Finally, select the dictionary you 

want to use from the pop-up menu in the Character palette. (You do not need to select 

the text with the Type tool.) 
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• To designate a language dictionary for individual words on a text layer, use the Type tool 

to select (highlight) those words, and then select the dictionary in the Character palette. 

Each word can be associated with only one language dictionary, but you can use as many 

different dictionaries as you need to check different words in your Photoshop files.

7 Layer comps make various combinations of layer settings available as a single-click 

action. These settings can include layer visibility, layer position, and layer effects, such as 

opacity and layer styles. In Photoshop, this is especially useful when you want to create 

alternate design choices for review or when the final output will include multiple versions 

of the file, each of which is directed to a different audience. In ImageReady, layer comps 

can be a tremendous time-saver for creating GIF animations, which you’ll learn more 

about in Lesson 18, “Animating GIF Images for the Web.”
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