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chap ter

18

Some Web designers handcraft sites with loving care, changing layouts, colors, 
fonts, banners, and navigation from page to page. But that approach isn’t always 
practical—or desirable. Consistency is a good thing. Web pages that look and act 

similarly reassure visitors; when only important material changes from page to page, 
readers can concentrate on fi nding the information they want. Even more importantly, 
a handcrafted approach is often unrealistic when you’re designing on a deadline. 

Here’s where templates come in. Frequently, the underlying design of many pages 
on many Web sites is identical (see Figure 18-1). For instance, a company Web site 
with an employee directory may dedicate a single Web page to each employee. Each 
employee page probably has the same navigation bar, banner, footer, and layout. Only 
a few particulars differ, like the employee name, photo, and contact information. 

Template Basics
Templates let you build pages that share a similar structure and graphic identity, 
quickly and without having to worry about accidentally deleting or changing ele-
ments. They come in very handy when you’re designing a site for which other, less 
Dreamweaver-savvy individuals are responsible for adding new pages. If you use a 
template, these underlings will be able to modify only the areas of a page that you, 
the godlike Dreamweaver guru, defi ne. 

Tip: Macromedia Contribute, a simple, word processor–like program for updating Web sites, works very 
well with sites built using Dreamweaver templates. If you build sites that are updated by people who don’t 
know the fi rst thing about Dreamweaver or building Web pages, Contribute can help.

Templates



566 dreamweaver mx 2004: the missing manual

A new page based on a template—also called a template instance—looks just like 
the template, except that you can only edit certain areas of the page, called, logically 
enough, editable regions. In the example shown in Figure 18-1, one editable region 
includes the question-and-answer text area; the rest of the page remains untouched 
and is, in fact, locked. 

Template Basics

Figure 18-1:
These three Web pages 
are part of a section of 
a Web site dedicated to 
answering frequently 
asked questions. The 
pages each provide the 
answer to a differ-
ent question, but are 
otherwise identical, 
sharing the same ban-
ner, navigation buttons, 
sidebar, and footer. 

This is a common sce-
nario for Web sites that 
include news stories, 
employee profi les, 
product pages, or press 
releases. In fact, it’s so 
common that Dream-
weaver has a special 
feature—Templates—to 
help you build such 
pages.
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A Dreamweaver template can be very basic: one or more areas of a page (called ed-
itable regions) can be changed, others can’t (locked regions). But Dreamweaver also 
includes many subtle ways for controlling template instances. Here’s an overview of 
the features you’ll encounter when creating and using templates: 

 • Editable regions. These are the basic building blocks of a template. (They work 
the same as they did in earlier versions of Dreamweaver.)

An editable region is a part of a page—a paragraph, table cell, or headline, for 
example—that people can change on each template instance. A template page can 
have multiple editable regions—for example, one in a sidebar area and another in 
the main content section of a page. 

 • Editable tag attributes. There may be times when you want to make a particular 
tag property editable. For instance, if you want to specify a different background 
color for each page, you’ll want to permit changes to the <body> tag’s Bgcolor 
property. 

Or perhaps you’ve built a template that includes a photo with some complex for-
matting (left-aligned by a Cascading Style Sheet, perhaps). Turning the entire image 
into an editable region could pose problems: When someone creates a new page 
from the template and then inserts a new photo, all of the formatting information 
can get lost. Instead, you could make just the image’s Src property editable. People 
would then be able to insert new images for each page without inadvertently ruin-
ing the photo’s formatting. (If the Width and Height properties vary from image 
to image, you can also make those attributes editable.)

 • Repeating regions and repeating tables. Some Web pages include lists of items: 
catalogs of products, lists of news articles, albums of photos, and so on. Dream-
weaver lets you defi ne repeatable regions for pages like this. 

For example, a page of product listings might include a picture, name, and price 
for each product in a catalog, organized using a table with multiple rows (Chapter 
7). 

As template builder, you may not know in advance how many products the page 
will eventually list, so you can’t fully design the page. However, you can use Dream-
weaver to defi ne a row—or any selection of HTML—as a repeating region, so that 
page authors can add new rows of product information when needed. 

 • Optional regions and editable optional regions. Optional regions make templates 
even more fl exible. They let you show or hide content on a page-by-page basis. 

Suppose you create a template for your company’s products. When some products 
go on sale (but others remain full price), you could add an optional region on the 
template that displays a big “On Sale!” logo. When creating a new product page, 
you could show the optional region for products that are on sale and keep it hid-
den for the others. 

Editable optional regions are similar, but they have the added benefi t of being 
editable. Maybe you’re creating a template for an employee directory, giving each 

Template Basics
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employee a separate Web page with contact information. Some employees also 
want their picture displayed on the page, while others don’t (you know the type). 
Solution: Add an editable optional region that would let you show the space for 
a photo and add a different photo for each page. For the shier types, you would 
simply hide the photo area entirely. 

Note: If you’re coming from Dreamweaver 4, the way Dreamweaver creates templates has changed sig-
nifi cantly—so much, in fact, that Dreamweaver 4 doesn’t understand templates created by Dreamweaver 
MX 2004 (or Dreamweaver MX for that matter). However, if you’ve created a site using Dreamweaver 4’s 
Template tools, Dreamweaver MX 2004 does understand those, so you can upgrade to MX 2004 and still 
use them to build new pages. 

Or better yet, update the old style template information to the newer MX template code following this tutorial: 
www.dreamweavermx-templates.com/tutorials/tutupdate.cfm.

Furthermore, Dreamweaver can create nested templates, which inherit design elements 
from a master template. In this way, you can create a general unifi ed design that’s 
shared by other templates; this feature is described on page 587. 

But facilitating page creation is only one of the benefi ts of templates. You’ll also fi nd 
that templates can greatly simplify the process of updating the design of a Web site. 
Like Library items, pages based on templates retain a reference to the original template 
fi le. Any changes made to the template pass on to all pages created from it, which can 
save you hours of time and trouble when it comes time to update the look or structure 
of your site. Imagine how much time you’ll save when your boss asks you to add “just 
one more” button to the site’s navigation bar. Instead of updating thousands of pages 
by hand, you’ll need to update only a few template fi les.

Create a Template
The fi rst step in creating a template requires building a basic Web page and telling 
Dreamweaver you’d like to use it as a Template. You can go about this in two ways: 
build a Web page and turn it into a template, or create a blank empty Template fi le 
and add text, graphics, tables, and other content to it. 

Turning a Web Page into a Template
The easiest way to create a template is simply to base it on a Web page in your current 
site folder. Although you can create templates based on Web pages that aren’t part of 
the current local site, you may run into problems with links and paths to images, as 
described in a moment. 

Once you’ve opened the Web page, just choose File→Save As Template or, on the 
Common tab of the Insert bar (see Figure 18-2), click the Templates button and se-
lect Make Template from the menu. In the Save As Template window (Figure 18-3), 
the name of the current local site appears in the Site pop-up menu; meanwhile, all 
templates for that site show up in the Existing Templates fi eld.

Template Basics
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Note: At this point, you could theoretically use the Site menu to save a template into any local site folder 
you’ve defi ned (see Chapter 14 for a discussion of local sites), but be careful with this option. If your page 
contains images and links and you save it as a template for another local site, Dreamweaver won’t copy the 
images from the fi rst site folder into the other one. As a result, the paths to the image fi les and links won’t 
work correctly. 

If you must use a page from one site as a template for another, copy the Web page and graphics into the 
new site’s root folder, open the page from there, and then create a template as described here.

Finally, type a name for the new template, and then click Save. Choose Yes when 
Dreamweaver asks if you want to Update Links for the page. If you choose No, all 
page-relative links will break, and all the images on the page will appear as broken 
image icons. 

Dreamweaver saves the page in the Templates folder of your local site root folder. It 
adds the extension .dwt to the fi le to indicate that it’s a Dreamweaver template. (For dy-
namic Web pages, Dreamweaver adds the .dwt before the fi le’s extension. For example, 
an Active Server Page template might have a name like maintemplate.dwt.asp.)

Figure 18-2:
The Templates menu on the Common tab 
of the Insert Bar provides access to tools for 
creating templates and setting up a variety of 
Dreamweaver template features. 

Figure 18-3:
The Save As Template dialog box lets you save your 
template into any of the local site folders you’ve 
defi ned in Dreamweaver. Stick to your current local 
site to avoid broken links and similar problems.

Create a Template
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Building a Template from Scratch
It’s easiest to create a Web page fi rst and then save it as a template, but you can also 
build one from scratch. Open the Asset panel’s Templates category by choosing Win-
dow→Assets and clicking the Template icon (see Figure 18-4). Then click the New 
Template button at the bottom of the Assets panel. Once Dreamweaver adds a new, 
untitled template to the list, type a new name for it. Something descriptive like “press 
release” or “employee page” will help you keep track of your templates.

After you’ve created a blank template for the site, you can open it by double-clicking 
its name in the Assets panel (or selecting its name and then clicking the Edit button 
at the bottom of the Assets panel). It opens just like any Web page, so that you can 
get busy designing it.

Defi ne Editable Regions
Your next project is to specify which parts of your template are locked, and which are 
editable. By default, everything on a page is locked. After all, the main reason to use 

The Broken-Link Blues
Why aren’t the links in my templates working?

When you created the link, you probably typed a path into 
the Property inspector’s Link fi eld—a recipe for heartbreak. 
Instead, always select the target Web page for a link by 
clicking the folder icon in the Property 
inspector, or by pressing Ctrl+L (c-L). 
In other words, when adding links to a 
template, always link to pages within the 
site by browsing to the desired fi le. 

Dreamweaver saves templates in the Tem-
plates folder inside the local root folder; 
all relative links need to be relative to this 
location. (Absolute links, like those to other 
Web sites, aren’t a problem; see page 93 
to learn the difference.) The reason you 
should browse to, rather than type in, your 
links is so that Dreamweaver can create a 
proper relative link.

Imagine this situation: You create a template for your clas-
sifi ed ads. You store all classifi ed ads for April 2001 inside a 
series of folders like this: classifi eds→2001→april, as shown 

in the site diagram here.

A link from a page in the april folder to the home page would 
follow the path marked 1 here. So when you create a link in 
your template, you might create a link to the home page by 

typing the path ../../../index.html. 

That’s a logical choice if you’re thinking 
about the page (in the april folder) you’ll 
create from the template—but it won’t 
work. Dreamweaver stores templates in 
the Templates folder, so the correct path 
would be path 2, or ../index.html. When 
you create a new page based on the 
template and save it in the april folder, 
Dreamweaver, in its wisdom, automatically 
rewrites all paths in the page so that the 
links function correctly. 

The beauty of Dreamweaver is that you 
don’t have to understand how all this 

works. Just remember to use relative links in your templates 
and create them by clicking the folder icon in the Property 
inspector. 

FREQUENTLY ASKED QUESTION

1

2

Create a Template
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templates is to maintain a consistent, unchanging design and structure between pages. 
To make a template usable, you must defi ne the area or areas you can change.

Figure 18-4:
The Templates category of the Assets panel 
lists the name, fi le size, and location of each 
template in the current local site. The Apply 
button applies a template to the current open 
Web page. The Refresh Site List button updates 
the list of templates. (In general, Dreamweaver 
does a very good job of keeping the list up to 
date, so you’ll rarely need this button.) The 
New Template button creates a new blank tem-
plate in the Templates folder. Select a template 
from the list and click the Edit Template button 
to open the template for editing. 

Apply Selected
Template to Page

Templates in
the current site

Refresh List New Item

Delete
Edit

Template
Assets

Preview

Figure 18-5:
This page is based on a template 
called Horoscope, as you can tell 
from the little tab in the document 
window’s upper-right corner. 
You can modify editable regions, 
which are labeled with small 
tabs. In this example, the editable 
regions are called horoscope and 
signImage. An additional editable 
region appears within a repeating 
region—labeled repeatCelebrity—
which lets you duplicate editable 
regions to form a list of items. The 
title of any page created from a 
template is also editable. All other 
parts of the page are locked; you 
can only make changes to the 
original template fi le.

Template nameTabs of editable regRepeating region ions

Defi ne Editable 
Regions
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Adding a Basic Editable Region
To add an editable region to a template, start by selecting the part of the page you 
want to make changeable. You can incorporate anything in the document window 
(any HTML between the <body> tags). 

Note: The <head> of a page is always editable. You can add Custom Style Sheets, JavaScript and meta 
tag information freely to any page created from a template. In fact, there’s no way to prevent anyone from 
messing around with the page’s head.

Drag across your page to select the elements you wish to make editable, or, for greater 
precision, use the tag selector (page 20) to make sure you select the exact HTML you 
want. 

Now tell Dreamweaver that the selected elements are to be editable. You can use any 
of these techniques:

 • In the Common tab of the Insert bar (Figure 18-2), select Editable Region from 
the Template menu.

 • Choose Insert→Template Objects→Editable Region.

 • Press Ctrl+Alt+V (Option-c-V).

 • Right-click (Control-click) the selection and choose Templates→New Editable 
Region from the contextual menu.

Under the Hood of Templates
Dreamweaver saves templates as HTML fi les in the Templates 
folder inside your current local site folder (see Chapter 14 for 
information on local sites). Each template bears the fi le name 
extension .dwt to distinguish it from regular Web pages. 

The program treats fi les in the Templates folder differently 
than normal Web pages, so don’t save anything but .dwt 
fi les there. In addition, since Dreamweaver expects the 
Templates folder to be in the local root folder of your site, 
don’t move the Templates folder, or change its name in any 
way (don’t even change the capital T in Templates, even if 
you’re a low-key type of person). If you do, your templates 
won’t work. 

As with Library items, Dreamweaver uses HTML comment 
tags to indicate the name of the template. If you inspect a 
template-based document’s HTML code (see Chapter 10), 
you’ll see that, immediately following the opening <html> 

tag, Dreamweaver inserts a comment tag with the text In-
stanceBegin template followed by the location and name of 
the template. Additional comment tags indicate areas of the 
page that you can modify, plus special template features like 
template parameters used for optional regions. For instance, 
the title of a page based on a template is always editable; its 
comment tag might look like this:

<!-- InstanceBeginEditable 

name="doctitle" -→
<title>My New Page</title>

<!-- InstanceEndEditable -−>

The fi rst comment indicates the editable region’s beginning 
and also includes the editable region’s name. When editing 
pages based on the template, you can change only the HTML 
between these comment tags. Everything else on the page is 
locked, even when you’re working in Code view.

POWER USERS’ CLINIC

Defi ne Editable 
Regions
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When the New Editable Region dialog box appears, type a name for the region (you 
can’t use the same name twice) and click OK. You return to your template, where 
the name you gave the region appears in a small blue tab above the editable region 
(see Figure 18-5).

Tip: If you use tables to lay out your pages (see Chapter 7), you’ll often assign one table cell as the main 
area to hold the primary content of the page. For example, in the pages shown in Figure 18-1, the Frequently 
Asked Question and its answer appear in a single cell on the page. This cell makes a perfect editable region for 
a template. In the tag selector, just click the <td> tag associated with that cell and use any of the techniques 
discussed here to convert the contents of that cell into an editable region. 

If you use CSS, on the other hand, you might create a separate <div> tag (page 272) for the main content 
area. In this case, select just the contents of the <div>, not the tag itself. If you turn the <div> tag into an 
editable region, it’s possible for someone modifying the page later to delete the tag entirely, which could 
wreak untold havoc on your CSS-based layout. 

Unfortunately, selecting all of the text inside a <div> frequently selects the <div> tag, too. You may need to 
go into Code view (page 324) and make sure that you’ve selected only the content inside the tag.

Hindered by Highlighting
I’m distracted by the tabs and background colors that 
Dreamweaver uses to indicate Library items and Templates. 
How do I get rid of them?

When you use Library 
items or Templates, you’ll 
see blue tabs and yel-
low backgrounds to indi-
cate editable regions and 
Library items. Although 
these visual cues don’t 
appear in a Web browser, 
they can still make your 
page harder to read while 
working in Dreamweaver. 
Fortunately, you can alter 
the background color of 
these items and even turn 
highlighting off altogether. 

Choose Edit→Preferences or press Ctrl+U (c-U). In the 
Preferences Category list, click Highlighting. To change the 

background color for editable regions, locked regions, and 
Library items, use the color box (see page 35) or type in a 

hexadecimal color value. 
To remove the highlight-
ing, turn off the Show box 
next to the appropriate 
item. 

Oftentimes, it’s useful to 
keep highlighting on to 
help you keep track of 
Library items and editable 
regions. If you want to turn 
off highlighting temporar-
ily, simply choose View→
Visual Aids→Invisible Ele-
ments, or use the keyboard 
shortcut Ctrl+Shift+I (Shift-

c-I) to toggle these visual cues off and on. This technique 
has the added benefi t of hiding table borders, layer borders, 
and image maps, as well as other invisible elements.

FREQUENTLY ASKED QUESTION

Defi ne Editable 
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You may fi nd that a single editable region is all you need—for example, a single table 
cell containing the text for a product review. However, if you need to edit multiple 
areas of a Web page, just add more editable regions to the template. For instance, 
when you create a template for an employee page, you might create editable regions 
for the employee’s name, telephone number, and photo.

If you change your mind and want to lock a region again, select the editable region 
and choose Modify→Templates→Remove Template Markup. Dreamweaver removes 
the code that makes the region editable. You can do the same thing with other types 
of template regions, like repeating and optional regions.

Figure 18-6:
A repeating region lets page authors add 
multiple selections of repeating informa-
tion. Top: In this example, the template has 
one repeating region, labeled repeatCeleb-
rity (circled). 

Bottom: A complete page based on this 
template includes three repeated editable 
regions (circled in the lower right of the 
page). If another page requires more 
celebrity listings, you could easily add 
additional rows to each list. However, the 
template still controls the basic design. 
Changing the star graphic of the repeating 
region (an uneditable part of the region) in 
the template page automatically changes 
the same elements in all pages created 
from the template. From a design perspec-
tive, this strategy also means that page 
authors can’t tamper with the design of a 
repeating region—just the content marked 
as editable.

Defi ne Editable 
Regions
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Warning: You can rename an editable region by clicking the blue tab on the template page and typing a 
new name into the Property inspector. However, if you’ve already built pages based on this template, it’s not 
a good idea. Because template-based pages use the name to identify editable regions, Dreamweaver can lose 
track of where content should go when you rename a region. See Figure 18-18 for a workaround. 

Adding a Repeating Region
Some Web pages contain lists of items. A catalog page might display row after row of 
product information—picture, name, price, and description. An index of Frequently 
Asked Questions might provide a list of questions and the dates they were posted. 

If you were to make a template for either of these pages, you would add an editable 
region to the area of the page where these lists appear. Just creating an editable region, 
however, wouldn’t give you any ability to enforce (or easily update) the design of these 
lists, because everything within an editable region can be changed. 

Fortunately, Dreamweaver provides a pair of template tools to overcome this prob-
lem: repeating regions and repeating tables. Both let you create areas of a page that 
include editable (and uneditable) regions that can be repeated any number of times 
(see Figure 18-6). 

Adding a repeating region is similar to adding an editable region. Select the area of 
the template page you wish to make repeatable, which usually contains at least one 
editable region. Most often, this area will be a table row, so you could select the row 
(<tr> tag) with the information to be repeated. You could just as easily select a para-
graph or a list item (<li> tag).

Tip: You can make a repeating region that doesn’t include an editable region. For example, a template for 
a movie review Web page could include a repeating region that’s simply a graphic of a star. A page author 
adding a new movie review could repeat the star graphic to match the movie’s rating—4 stars, for example. 
(There’s just one caveat—see the Warning on page 593.)

Now tell Dreamweaver that the selected elements are part of repeating region. You 
can use any of these techniques:

 • On the Common tab of the Insert bar (Figure 18-2), select the Repeating Region 
option from the Templates menu.

 • Choose Insert→Template Objects→Repeating Region.

 • Right-click (Control-click) the selection and choose Templates→New Repeating 
Region from the contextual menu.

When the New Repeating Region dialog box appears, type a name for the region and 
click OK. You return to your template, where the name you gave the region appears 
in a small blue tab above the editable region (see Figure 18-6). (See page 592 for a 
discussion of using a repeating region when building a new template-based page.)

Defi ne Editable 
Regions
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Warning: Dreamweaver MX lets you name a repeating region with a name already in use by an editable 
region. But don’t—multiple template areas with the same name will cause Dreamweaver to act unpredict-
ably.

Repeating tables
The new repeating table tool is essentially a shortcut to creating a table with one or 
more repeating rows in it. If you had a lot of time on your hands, you could achieve 
the same effect by adding a table to a page, selecting one or more rows, and applying 
a repeating region to the selection. To use the repeat table tool:

 1. Click on the template page where you wish to insert the table.

You can’t insert a repeating table into an already defi ned editable, repeating, or 
optional region, as explained in the box below. You must be in an empty, locked 
area of the template.

 2. On the Common tab of the Insert bar (Figure 18-2), select the Repeating Table 
option from the Templates menu.

Alternatively, you can choose Insert→Template Objects→Repeating Table. Either 
way, the Insert Repeating Table window appears (Figure 18-7).

 3. Fill out the basic properties of the table.

The top part of the window lets you set up the basic structure of the table: rows, 
columns, cell padding, cell spacing, width, and border. Basically, it’s the same in-
formation you’d provide when creating any table, as described on page 216. You 
usually start a repeating table with two rows—one for a heading, and another to 
contain the information you wish to repeat. 

Editable Regions, Repeating Regions, and Errors
When I try to insert an editable region inside a repeating 
region, I get the following error: “The selection is already 
in an editable, repeating, or optional region.” What’s that 
about?

This error message essentially means you’re trying to add a 
template region where it doesn’t belong. It most commonly 
appears when you attempt to put a repeating or optional 
region inside an editable tag. That kind of nesting is a no-
no; anything inside an editable region can be changed on 
template-based pages, and as such Dreamweaver can’t 
touch it. 

However, you may get this error message seemingly in er-
ror. For instance, it’s perfectly OK to add an editable region 

inside a repeating region, and even to add a repeating region 
inside of an optional region, and vice versa. But one day you 
select text inside a repeating region and try to turn it into an 
editable region, and boom—error message. What probably 
happened was, when you selected the text, Dreamweaver 
actually selected part of the hidden code used to defi ne a 
template region (see “Under the Hood of Templates” on 
page 572) and thought you were trying to put an editable 
region inside of it. To avoid confusion, use the tag selector 
to select the tag you wish to turn into an editable region. For 
example, click <p> in the tag selector to select the paragraph 
inside the repeating region. Alternatively, go into Code view 
(page 324) and select whatever part of the code inside the 
repeating region you wish to make editable.

FREQUENTLY ASKED QUESTION

Defi ne Editable 
Regions



 chapter 18: templates 577

 4. In the Starting Row box, type the number of the row where the repeating region 
should begin.

Often you’ll just have one repeating row: one row of product information, for 
example. You might want to use the top row for labels indicating the information 
contained in the rows below. If that’s the case, enter 2 at this step, leaving the fi rst 
row as an uneditable part of the template. 

It’s conceivable, however, that you might want each entry to take up two rows. The 
fi rst would list Name and Description; the second would contain a cell for a photo 
and a cell for the price. You set up this effect in this step and the next. 

 5. In the Ending Row box, type the number of the last repeating row.

If you only wish to repeat a single row, enter the same number you provided for 
step 4. If you’re creating a double repeating row, add 1 to the number you provided 
in step 4. If you need three rows for each repeating entry, add 2 to the number 
from step 4.

 6. Type a name for this repeating region.

Don’t use the same name as another template region. You’ll run the risk of unpre-
dictable results on template-based pages.

 7. Click OK.

Dreamweaver inserts a table into the page. A blue tab with the name of the repeat-
ing region appears (see Figure 18-6), as do blue tabs in each cell of each repeated 
row. These tabs indicate new editable regions—one per cell. 

Since these new editable regions have uninformative names like EditRegion4, you 
might want to rename them. Click the blue tab and type a new name in the Prop-

Figure 18-7:
The Insert Repeating Table dialog box lets 
you kill three birds with one stone: It adds 
a table to a page, turns one or more rows 
into a repeating region and adds editable 
regions into each table cell inside the 
repeating region.

Defi ne Editable 
Regions
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erty inspector. (But do so before you create any pages based on the template—see 
the Warning on page 575.)

To remove a repeating region, select it by clicking the blue Repeat tab and choose 
Modify→Templates→Remove Template Markup. A more accurate way to select a 
repeating region is to click anywhere inside the region and then click “<mmtemplate: 
repeat>” in the tag selector. (See page 20 for more on using the tag selector.) If you 
want to rename a repeating region, heed the Warning on page 576.

Making a Tag Attribute Editable
An editable region lets you change areas of HTML—like a paragraph, image, or entire 
table—on new pages you create from a template. However, when you’re creating a 
template for others to make pages from down the line, you may want to limit these 
page authors’ editing abilities. You may want to allow budding Web designers to 
change the color of a table cell without changing other properties like cell width or 
paragraph alignment. You can use Dreamweaver’s Editable Tag Attribute to specify 
which tag properties your successors can change.

Tip: Before making a tag attribute editable, fi rst set that property to a default value in the template. Doing 
so inserts a default value and makes the attribute appear in the Editable Tag Attribute window (see steps 3 
and 7 below). 

To make a tag attribute editable:

 1. Select the tag whose property you wish to make editable.

Using the tag selector (page 20) is the most accurate way.

 2. Choose Modify→Templates→Make Attribute Editable.

The Editable Tag Attributes window opens (Figure 18-8).

Figure 18-8:
Dreamweaver provides detailed control 
for template pages. To make just a single 
property of a single tag editable when pages 
are later based on your template, turn on 
the “Make attribute editable” checkbox. In 
this case, the “class” attribute of the body 
tag will be editable, allowing page designers 
the freedom to apply different CSS styles to 
the body of each template-based page.
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 3. Select an attribute from the menu or add a new attribute with the Add button.

Only properties you’ve already set for the selected tag appear in the Attribute 
menu. In other words, if you’ve selected an image, you’ll probably see the Src, 
Width, and Height properties listed. But unless you’ve set the image’s border, the 
Border property won’t appear.

To add a property, click the Add button. In the window that appears, type the ap-
propriate property name. For example, to make the path to a graphics fi le editable, 
you’d set the <img> tag’s Src attribute by typing src here. (If you’re not sure of the 
property’s name, check out Dreamweaver’s built-in HTML reference, described 
on page 335.)

Tip: If you want page editors to be able to change a CSS class applied to the <body> tag on template-based 
pages—to apply different fonts, background colors, or any of the many CSS formatting options to each tem-
plate-based page—you have to make the Class attribute editable. (See page 150 for more on CSS classes.)

 4. Make sure the “Make attribute editable” box is turned on. 

If you decide that you no longer want to allow editing of this property, you can 
return to this dialog box and turn off editing, as described on page 580.

 5. Type a name in the Label fi eld.

What you type here should be a simple description of the editable tag and property, 
which will help page authors correctly identify editable properties. For example, 
you could use Product Image if you’re making a particular image’s source (Src) 
property editable.

 6. Choose a value type from the menu.

Your choices are:

Text. Use this option when a property’s value is a word. For example, the image tag’s 
Align property can be top, middle, baseline, and so on. Or, when using Cascading 
Style Sheets, you could make a tag’s Class property editable to allow page authors 
to apply a particular custom style to the tag—content, footer, and so on.

URL. Use this option when the editable property is a path to a fi le, like an image’s 
Src property or a link’s Href property. Using its site management tools, Dream-
weaver will keep track of these paths and update them when you move your pages 
around your site.

Color. If the property requires a Web color, like a page’s background color, select 
this option. It will make Dreamweaver’s color box available to people who build 
pages from the template.

True/False. You shouldn’t use this option. It’s intended for Dreamweaver’s Op-
tional Regions feature (discussed on page 580), and it doesn’t apply to HTML 
properties.
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Number. Use this choice for properties that require a numeric value, like an image’s 
Height and Width properties. 

 7. Type a default value into the Default fi eld.

This step is optional. The default value defi nes the initial value for this property, 
when people fi rst create a page based on the template. They can then modify this 
value for that particular page. If you’ve already set this property in the template, 
its value will appear automatically in this box.

 8. Click OK to close the window.

Dreamweaver adds code to the template page that allows page authors control of 
the attribute. Setting this attribute on pages created from the template is described 
on page 593.

If you later decide that you don’t want a particular tag’s property to be editable, Dream-
weaver can help. Open the template fi le, select the tag with the editable attribute, and 
choose Modify→Templates→Make Attribute Editable. In the window that appears, 
turn off the “Make attribute editable” checkbox (Figure 18-8). Unfortunately, doing 
so doesn’t remove all of the template code Dreamweaver added. Even after you turn 
off editing for an attribute, Dreamweaver leaves behind the parameter used to control 
the tag’s property. To eliminate this extra code, see the box on page 599. 

Adding Optional Regions
Templates provide consistent design. While that’s generally a good thing, it can also 
get boring. Furthermore, there may be times when you’d like the fl exibility to include 
information on some template-based pages but not on others. 

Dreamweaver provides a fairly foolproof way to vary page design: optional regions. 
An optional region is simply part of a template page that can be hidden or displayed 
on each template-based page (see Figure 18-9). When creating a new page based on 
the template, a page author can turn the region on or off. 

Creating an optional region is a snap. Just select the HTML code you wish to make 
optional, and then do one of the following:

 • On the Common tab of the Insert bar (Figure 18-2), select the Optional Region 
option from the Templates menu.

 • Choose Insert→Template Objects→Optional Region.

 • Right-click (Control-click) the selection and choose Templates→New Optional 
Region from the contextual menu.

In the New Optional Region window, type a name (see Figure 18-10). Make sure not 
to use the same name as any other region on the page, and—although Dreamweaver 
allows it—don’t use spaces or other punctuation marks. (Following the rules for nam-
ing fi les as described on page 456 is the best method, and ensures that the optional 
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region will work properly.) Click OK to close the window and create the new Optional 
region. Dreamweaver adds a light blue tab with the word “If” followed by the name 
you gave the region (Figure 18-9). 

Figure 18-9:
Now you see it, now 
you don’t. Optional 
regions let you show or 
hide content on a page-
by-page basis. In these 
examples, the template 
page has an optional 
region containing a 
“Sign of the Month” 
button indicated by 
the blue tab with the 
label If signOfMonth 
(top). When creating a 
template-based page 
from this template, 
you can either display 
the optional region 
(bottom right) or hide it 
(bottom left).

Template

Optional
region

Template-based
pages

Figure 18-10:
The Optional Regions 
feature lets you show or 
hide specifi c content on 
template-based pages. 
Turning on “Show by de-
fault” tells Dreamweaver 
to display the region 
when a page author fi rst 
creates a template-based 
page. Turn this box on if 
the optional region needs 
to show on most pages. 
You’ll save someone 
the effort of turning the 
region on each time she 
creates a new template-
based page. 
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Locking optional regions
An optional region can include editable and repeating regions and locked regions. 
For example, if you simply want to allow a page author to turn on or off a graphic 
(“This item on sale!!!!”), insert the graphic into a locked area of the page (page 567), 
and make it an optional region as described above. In this way, a page author won’t be 
able to change the graphic or ruin its formatting—only make it visible or hidden. 

Repeating optional regions
An optional region can also include repeating regions. For example, suppose you 
create a repeating region (page 575) that lets a page author add row after row of links 
to a list of related articles. You could then turn this repeating region into an optional 
region, as described above, so that if a particular page had no related articles, the 
author could simply hide the entire “related articles” section of the page.

Optional editable regions
Dreamweaver’s Optional Editable Region command inserts an optional region with 
an editable region inside it. To use it, click in the template at the spot where you’d 
like to add it, and choose Insert→Template Objects→Optional Editable Region (al-
ternatively, you can choose this option from the Templates menu on the Common 
tab of the Insert bar). The New Optional Region window appears; give it a name and 
follow the same steps outlined above for an optional region. 

This technique doesn’t offer a lot of control; it’s hard to insert HTML outside the ed-
itable region, for example. So if you want to have an image or table that is optional but 
not editable, it’s usually better to just create the editable region as described on page 
570 and turn it (and any other HTML you wish to include) into an optional region.

Tip: The Optional Editable Region command doesn’t let you name the editable region; instead you’ll get 
a generic name like EditRegion7. You can select the editable region and change its name in the Property 
inspector, but do so before you build any pages based on this template (see the Warning on page 575).

Advanced Optional Regions
Optional regions are rather simple affairs: They either appear or they don’t. But 
Dreamweaver offers more complex logic for controlling optional regions. For ex-
ample, maybe you want several different areas of a page to be either hidden or visible 
at the same time—perhaps an “On Sale Now!” icon at the top of the page and a “Call 
1-800-SHIZZLE to order” message at the bottom of the page. When one appears, so 
does the other.

Because these objects are in different areas of the page, you have to create two separate 
optional regions. Fortunately, using Dreamweaver’s advanced settings for optional 
regions, you can easily have a single region control the display of one or more ad-
ditional areas of a page. Here’s how to do it: 

 1. Create the fi rst optional region using the steps on page 580.
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Give the region a name using the Basic tab of the New Optional Region window 
(Figure 18-10).

 2. Select the part of the page—an image, paragraph, or table—that you wish to turn 
into a second optional region.

In this case, you’ll make the display of this region dependent on the optional 
region added in step 1. If the fi rst region is visible on the page, this region will 
also show. 

 3. On the Common tab of the Insert bar (Figure 18-2), choose the Optional Region 
item from the Templates menu.

The New Optional Region window appears. 

 4. Click the Advanced tab.

The optional region’s advanced options appear (see Figure 18-11). In this case, 
you want the fi rst optional region you created to control the display of this new 
region. So instead of giving this region a name, simply select the name of the fi rst 
optional region.

 5. Click the Use Parameter button and select the name of the fi rst optional region 
from the menu.

This step is what makes the fi rst optional region control this region. If a page author 
displays the fi rst region, this second region will also appear.

 6. Click OK to close the window and create the new optional region.

Figure 18-11:
The New Optional 
Region box lets you more 
precisely control the 
display of an optional 
region. You can make the 
region appear only when 
another region is visible, 
or use Dreamweaver’s 
template expression lan-
guage to create a more 
complex behavior. In this 
case, the selected region 
will appear only when 
another region—named 
OnSaleBug—is not visible 
(the ! is a programming 
equivalent to “is not”).
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You can continue adding optional regions in this way, using the Advanced tab and 
selecting the name of the fi rst optional region from the menu. This way, a single 
region can control the display of many other areas of the page. 

Even fancier tricks
You can use these advanced controls for even more elaborate Web page stunts. For 
example, say your site is composed of several sections. When a visitor is in one section 
of the site, its navigation button is attractively highlighted and a secondary navigation 
bar miraculously appears, offering links to other pages in that section. 

Using a template, you can add an optional region containing the highlighted section 
button. When you add the secondary navigation bar to the page, you’d make it an 
optional region controlled by the highlighted navigation button. Then, when you 
add a page to that section of the site, you’d simply show the optional region contain-
ing the highlighted button (Figure 18-12), causing the secondary navigation bar to 
appear as well.

Controlling regions with expressions
You can program even more complex behaviors using a basic expression language, 
loosely based on JavaScript, that Dreamweaver understands. For example, instead of 
having an optional region appear when another optional region is visible (as in the 
above example), suppose you want to have a region appear when another region is 
invisible. This arrangement can come in handy when you’re creating a navigation bar. 
When a page is in a particular section, for instance, the navigation button for that sec-
tion is highlighted, but the button isn’t highlighted if the page is in another section. 

In other words, you can build a single template for all the sections of the site, but 
control the appearance of the navigation bar separately for pages in each individual 
section (see Figure 18-12).

Here’s how you’d do that:

 1. Click in the page where you wish to insert the navigation buttons.

Figure 18-12:
An optional region 
on the page at left 
controls highlight-
ing of the top 
navigation button. 
By turning on a 
different optional 
region (right), the 
navigation system 
can highlight 
the site’s current 
section—“What is 
Electricity?”

Adding Optional 
Regions



 chapter 18: templates 585

 2. Insert the highlighted (“You are in this section”) navigation button.

This button could be a rollover image (see page 132) or just a single graphic. If you 
have multiple pages in the section, you’ll probably also want to link this graphic 
to the main page for that section.

 3. Click next to the highlighted button and insert the plain (“You can go here”) 
navigation button.

The button could also be a rollover image with a link to the main page for this 
section (for example, the main Products page).

 4. In the Property inspector, select the highlighted navigation button and link (if it 
has one).

This button will appear on any template-based page for this section. 

 5. On the Common tab of the Insert bar (Figure 18-2), choose Optional Region 
from the Template menu.

The New Optional Region window appears. Make sure the Basic tab is selected.

 6. Type the name of the section into the Name fi eld. Click OK.

For example, if this section of your site advertises your company’s products, you 
might call it products. Don’t use any spaces or punctuation other than hyphens 
(-) or underscores (_) for the name. Also make sure the “Show by default” box is 
not turned on. Since you’ll be building template-based pages for all the sections 
of your site, most pages you build will be in other sections of the site. Your work 
will go faster if this highlighted button starts out hidden. In the next steps, you’ll 
make the plain nav button appear by default.

 7. Use the Property inspector to select the plain button and link, and then click the 
Optional Region button on the Insert bar.

The New Optional Region window appears again, but this time you’ll use the 
advanced options.

 8. Click the Advanced tab; select Enter Expression (Figure 18-11).

You’re going to type an expression in the Expression fi eld. An expression is a 
programming statement that is either true or false. (For an obvious example, the 
statement 2=2 is true, but the statement 2=4 is false.) The important thing to 
remember here is that when an expression is true, the optional region is visible; 
when it’s false, it’s hidden. 

 9. Type an exclamation point (!) followed by the name you entered in step 6—!prod-
ucts, for example. 

Dreamweaver’s template expression language is based on the JavaScript pro-
gramming language. An exclamation mark means “not,” so this code means “not 
products.” A translation into non-caveman language: When the products region 
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(remember, that’s the highlighted button) is not displayed, this region (button) 
will appear on the page. 

The logic gets a little complicated, but have faith. When you add a new page based 
on this template, the optional region you added in step 6 is not visible (because you 
turned off the Show by Default box). In other words, because the region—products 
in this example—is not showing, this region, the one with the plain nav button, 
will by default appear on the page. Turning the products region on (as described 
on page 594), will therefore hide the plain nav button. In other words, the fi rst 
optional region works like a light switch, alternately turning on one or the other 
navigation button. 

 10. Click OK to close the window and add the additional optional region.

Repeat this process for each button in the navigation bar. When you’re fi nished, 
your template will be perfectly suited for displaying customized navigation bars 
for each section of your site. When you create a new template-based page, simply 

Understanding Template Parameters
When you insert an optional region, Dreamweaver adds 
special code to the head of the Web page. Called a template 
parameter, this code is responsible for showing or hiding 
an optional region. 

In fact, Dreamweaver uses parameters when you make a tag 
attribute editable, too. A typical parameter for an optional 
region might look like this:

<!-- TemplateParam name="SaleBug" 

type="boolean" value="true" -->

The <!-- and -->are HTML comments that hide this code 
from a Web browser. TemplateParam tells Dreamweaver 
that the comment is actually part of the program’s Template 
features—specifi cally, a template parameter. 

A parameter is composed of three parts: name, type, and 
value. The name is the name you gave the editable region. 
The type—Boolean—indicates that the value of this parameter 
can be only one of two options: true or false. In this example, 
the value is “true,” which simply means that the optional 
region called SaleBug will be visible. (Don’t worry; you don’t 
have to actually edit this code by hand to turn optional 
regions on and off, as you’ll see on page 594.)

In programming jargon, a template parameter is known as a 
variable. In simpler terms, it’s just a way to store information 

that can vary. Dreamweaver will react differently depending 
on this value: show the region if the parameter is true, or 
hide it if the parameter is false. 

Editable tag attributes also use parameters to store the values 
you enter for the tag attribute. For example:

<!-- TemplateParam 

name="PageColor" type="color" 

value="#FFFFFF" -->

On template-based pages, you can change the value of a 
parameter used for an editable tag attribute to change that 
tag’s property (page 593). 

Unfortunately, when you delete an optional region from 
a template, or remove the ability to edit a tag attribute, 
Dreamweaver always leaves these parameter tags hanging 
around in the head of the template document. Keeping in 
mind that Dreamweaver adds these parameter tags directly 
before the closing </head> tag, you can fi nd and remove 
unused parameter tags in Code view (see Chapter 10). 

For an excellent discussion of Template Parameters, in par-
ticular, and Dreamweaver Templates, in general, check out 
the book Dreamweaver MX Templates by Murray Summers 
and Brad Halstead.

POWER USERS’ CLINIC
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turn on the region for the particular section in which the page is located. (Hiding 
and showing optional regions is described on page 594.)

As you can see, optional regions are very powerful—and potentially confusing. But 
using even basic optional regions, you can exert a great deal of control over your 
template-based pages. For more information on template expressions and optional 
regions, take a look in Dreamweaver’s built-in Help system. (Press F1; then, in the 
window that appears, click the Search tab. Type template expressions in the box, and 
click the List Topic buttons. The Dreamweaver Help system then lists several articles 
related to templates and template expressions.)

Editing and Removing Optional Regions
After inserting an optional region, you can always return to the New Optional Region 
dialog box to change the region’s name, alter its default settings, and use advanced 
options. To edit an optional region, fi rst select it using one of these techniques:

 • Click the region’s blue tab in the document window (Figure 18-9).

 • Click anywhere inside the optional region in the document window; click the 
<mmtemplate:if> tag in the tag selector (see page 20 for details).

When you select an optional region, an Edit button appears in the Property inspec-
tor. Click it to reopen the New Optional Region window. You can then change the 
region’s properties.

To remove an optional region, select it using one of the techniques listed above and 
choose Modify→Templates→Remove Template Markup. Dreamweaver removes 
most of the code associated with the optional region (but see the box on the facing 
page). 

Nested Templates
Large sites may have many different sections or types of pages. Each section of the site 
or type of page may have its own unique look. A Frequently Asked Questions page 
may have distinct areas for a question, an answer, and links to further resources, while 
a product page may have a picture, a product description, and ordering information. 
You could create different templates for each type of page, but even that may be more 
work than necessary.

While many pages in a site may have subtle differences, they share very basic design 
features. The overall structure of every page, for example, may be the same: same logo, 
banner, and navigation bar. Even the basic layout may be the same. And there lies the 
problem with creating individual templates for each section: If you need to make a 
very basic sitewide change, like adding a new button to the site’s overall navigation 
system or altering the banner, you need to edit each template individually, adding 
extra time, effort, and risk of making a mistake. 

Fortunately, Dreamweaver offers a tool to solve just this problem: nested templates. A 
nested template is a template you make from another template, which then becomes 
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the master template (see Figure 18-13). Imagine a basic software company Web site 
with three sections: Support, Our Products, and Downloads. Each section has its own 
brand of information and specifi c layout needs. However, all three sections share the 
same banner and navigation. 

To create a template system for this site, you must fi rst create a very basic template 
that includes elements (including editable regions) shared by all pages—the master 
template. You would then create a nested template based on the master. On the nested 
template, you could add further design refi nements and additional editable regions 
for the areas that can be changed on pages created from the nested template.

Yes, this process sounds complex—and yes, it is. But when the alternative is hours or 
days of manual template updating, you can see why serious Web designers are willing 
to spend the time to master any shortcut they can get.

To create a nested template:

 1. Build a template as described on page 568.

This page will act as the master template and control all nested templates. It should 
include the basic elements shared by all nested template pages, like your logo and 
email links. Now is also the time to add editable regions in the areas the nested 
templates can change, like table cells to hold blocks of text and images. 

Figure 18-13:
Nested Templates (middle 
row) let you build tem-
plates that share common 
sitewide design elements 
while providing precise 
control for particular types 
of pages or sections of a 
Web site. A page built from 
a nested template (bottom 
row) contains both elements 
from a master template (top 
row)—like a banner and a 
sitewide navigation bar—in 
addition to elements specifi c 
to its nested template—like 
a section-specifi c secondary 
navigation bar. Changes you 
make to the master template 
are passed on to all pages 
of the site, including nested 
templates. Changes to a 
nested template, by contrast, 
pass on only to pages based 
on the nested template.

Master Template

Nested Templates

Pages built
from nested templatesLeggo my igloo

Lorem ipsum
dolor sat ignom
plentorum

Leggo my igloo
Lorem ipsum
dolor sat ignom
plentorum

Lorem Ipsum
Dolor Sat
Imperium

Lorem Ipsum
Dolor Sat
Imperium
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 2. Close, name, and save this template (File→Save as Template).

Your template is safe on the hard drive.

 3. Choose File→New.

The New Document window opens (see Figure 18-14).

 4. Click the Templates tab. In the “Templates for” list, select the Web site you’re 
working on.

You can open templates from any site you’ve defi ned in Dreamweaver.

 5. From the list of templates, select the name of the master template fi le you created 
in step 1.

Make sure the “Update page when template changes” box is turned on. Otherwise, 
the nested template won’t update when you edit the master template.

 6. Click OK.

Dreamweaver creates a new template-based page. At this point, it’s simply a basic 
Web page based on the original template. Next, you’ll turn it into a nested tem-
plate.

 7. Choose File→Save as Template. Or, on the Common tab of the Insert bar (Figure 
18-2), select Make Nested Template from the Templates menu.

The Save As Template window appears (see Figure 18-3).

 8. Type a name for the template and click the Save button.

Voila! A nested template. 

Figure 18-14:
You can use the “Templates for” list 
to choose another site you’ve defi ned 
and reveal the list of templates it 
uses. However, choosing a template 
stored in a different site is not a good 
idea. Dreamweaver doesn’t copy any 
images on the template to the current 
site and can’t translate relative links 
correctly. The result is broken links 
aplenty.
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Customizing Nested Templates
When you fi rst create a nested template, there’s no difference between it and the master 
template. They share the same design, content, and template regions. 

The next step is adding the design elements that are specifi c to pages built from that 
template. For example, you might add a special type of table for displaying a product 
photo, description, price, and other information. This table will appear only in pages 
built from this nested template, not from the master template or any other nested 
template.

There are a few things you should keep in mind:

 • When creating pages from templates, you can add content only to an editable 
region. That’s true not only for template-based pages, but for nested templates, 
too. If the master template has no editable regions, you won’t be able to change 
anything on the nested template created from it. 

 • When working on a nested template, you can insert an editable region only into an 
editable region supplied by the master template. For example, say you’ve created a 
master template to provide a consistent banner and navigation bar to the site, all 
in a locked region of the master template. Then you add a large empty area at the 
bottom of the page, and turn it into an editable region that you can customize to 
make specifi c layouts for each nested template. After creating a nested template 
from the master template, you can then add new editable regions to this open area. 
In fact, you can add any template region—repeating, optional, or editable—to 
this area. 

 • If, when working on a nested template, you insert a template region (editable, 
optional, or repeating) into an editable region supplied by the master template, 
pages based on the nested template can modify only those new regions. The rest 
of the editable region supplied by the master template is not editable on the pages 
based on the nested template. 

Using the example in the above paragraph, let’s say you next add a repeating table 
to your nested template (see page 576 for more detail about repeating tables). When 
you create a page based on this nested template, only the editable areas marked out 
in the repeating table can be changed. Of course, the other side of the coin is, if you 
add an editable region to the master template, and then refrain from adding any 
particular template regions, all of the HTML inside that region will be editable in 
the nested template and in all pages based on the nested template.

Using Nested Templates
Here’s an example of how you might use nested templates. Suppose you want to cre-
ate a uniform design for your site where every page of the site has a logo as well as 
a sitewide navigation bar. Each page within one section of the site also has a sidebar 
containing a secondary navigation bar containing navigation buttons for just that 
section. Finally, every page has a large content area to hold the information specifi c 
to that page.
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Using nested templates, creating a Web site like this couldn’t be easier. Create a master 
template containing the site banner and navigation bar. This template will also include 
editable regions for the sidebar and main content area. 

Next, create a nested template for one section of the site, leaving the content area 
as it is. Since each page will have its own content in this area, you don’t need to do 
anything to this region. Then add the secondary navigation bar to the sidebar area. 
To lock this region so no one can tinker with the sidebar (in pages built from the 
nested template), add an empty editable region, or see the Tip below. If desired, you 
can build similar nested templates for the other sections of the site.

Now you’re ready to start building the pages of your site. Create a new page based on 
one of the section templates. Add text or graphics to the editable content area of the 
page. Should you need to change the site logo or add a button to the sitewide navigation 
bar, open the master template, make the changes, save the fi le, and let Dreamweaver 
update all of the pages of your site with the new look. If you simply need to change 
the secondary navigation for one section of the site, then open the appropriate nested 
template, change the sidebar, save the template, and let Dreamweaver update all the 
section pages. 

Tip: You can lock an editable region passed from a master template to a nested template, so that pages 
based on the nested template can’t be changed in this region. In the nested template, go into Code view, 
locate the beginning of the editable region, which looks something like, <!-- InstanceBeginEditable 
name="regionName" -->.

Then insert the text @@("")@@ directly after the -->. 

If you fi nd yourself typing this code often, think about creating a snippet (see page 549) containing the text 
@@("")@@.

Building Pages Based on a Template
Building a template is only a prelude to the actual work of building your site. Once 
you fi nish your template, it’s time to produce pages. 

To create a new document based on a template, choose File→New to open the New 
from Template window (see Figure 18-14). Click the Templates tab and select the 
current site you’re working on from the “Templates for” list. All templates for the 
selected site appear in the right column. Select the template you wish to use and 
click Create. 

Tip: If you don’t want your new Web page linked to the template (so that changes to the template also af-
fect the Web page), turn off the “Update page when template changes” checkbox. The result is a new page 
that looks just like the template, but has no locked regions; you can edit the entire page. This method is 
useful, for example, when you want to start with the general design and structure of a certain template when 
creating a brand-new design for another template. (Be aware that Dreamweaver remembers this choice the 
next time you create a new page. In other words, future pages you try to create from a template will also be 
unlinked—unless you remember to turn back on the Update Page box.)

Nested Templates



592 dreamweaver mx 2004: the missing manual

A new Web page document opens, based on the template, bearing a tab in the upper-
right corner that identifi es the underlying template name. Dreamweaver outlines any 
editable regions in blue; a small blue tab displays each region’s name (Figure 18-5). 

Dreamweaver makes it painfully obvious which areas you aren’t allowed to edit; your 
cursor changes to a “forbidden” symbol () when it ventures into a locked area.

To add content to an editable region, click anywhere inside the editable region. You 
can type inside it, add graphics, or add any other objects or HTML you can normally 
add to a document. You can also change the document’s title and add Behaviors (see 
Chapter 12), Cascading Style Sheets (see Chapter 8), and meta tag information (items 
that go in the <head> of an HTML document).

Note: Dreamweaver doesn’t let you use the Layer tool to draw a layer in an editable region. That’s because 
using this method, Dreamweaver tries to add the code for the layer at the very beginning of the page, which 
is usually a non-editable region. Instead, you’re better off creating a CSS style using absolute positioning 
(page 265) and use the Insert Div Tag tool (page 272) to place a layer inside an editable region. 

If you’re designing sites to work with Netscape Navigator 4, don’t insert Layer code into a table cell, since 
Navigator 4 has trouble with that arrangement. The best solution is to add a single paragraph to the template 
fi le—at the very bottom of the page just before the closing </body> tag is a good place—and mark it as edit-
able. Then insert layers into this region of your template-based pages. 

Working with Repeating Regions
Repeating regions work a bit differently than editable regions. In most cases, a repeat-
ing region will include one or more editable regions (which you can edit using the 
instructions above). However, Dreamweaver provides special controls to let you add, 
remove, and rearrange repeating entries (see Figure 18-15).

Figure 18-15:
Repeating regions are a 
great way to quickly use 
lists in your Web pages. 
In this example, a list of 
links to related stories, you 
can add as many stories 
to the page as you’d like. 
Clicking the + button adds 
another row to this table 
complete with an icon (in 
a region locked by the 
template) and an editable 
story region.

Add new
repeating

entry

Move selected
entry up

Move selected
entry down Repeating region

Delete
entry
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These regions are intended to let a page author add repeated page elements—like 
rows of product information in a list of products. To add a repeating entry, click the 
+ button that appears to the right of the Repeat region’s blue tab. You can then edit 
any editable regions within the entry. Click inside an editable region inside a repeating 
entry and click + again to add a new entry after it.

Deleting a repeating entry is just as easy. Click inside an editable region within the 
entry you wish to delete and click the – button. 

Note: You can create repeating regions that don’t have any editable regions—for example, a star that can 
be repeated several times to indicate the rating for a product. Although you can use the + button to repeat 
such regions, you can’t delete those regions with the – button. In other words, you’re stuck with any extras 
you’ve added. The only workaround is to add an editable region to the repeating region. Then Dreamweaver 
lets you remove any repeating regions you wish.

To rearrange entries in the list, click inside an entry’s editable region. Click the up or 
down arrows to move the entry in the list (to alphabetize it, for example).

Changing Properties of Editable Tag Attributes
Unlike editable or repeating regions, an editable tag attribute isn’t immediately ap-
parent on template-based pages. There’s no blue tab to represent it, as there are for 
editable regions; in fact, nothing appears in Design view to indicate that there are any 
editable tag properties on the page. The only way to fi nd out is to choose Modify→
Template Properties to open the Template Properties dialog box (see Figure 18-16). 

All editable tag attributes for this page appear in this window. All parameters defi ned 
for this page, including optional regions, appear here, as discussed in the box on page 
586.

Building Pages 
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Figure 18-16:
The Template Properties 
window lets you control 
editable tag attributes 
and other parameters 
for optional regions. 
Depending on which 
parameter you select, the 
options at the bottom of 
the window change. In 
this case, since this page’s 
Bgcolor property is edit-
able, the PageBackground 
parameter lets you use 
Dreamweaver’s color box 
to select a new color for 
the background of the 
page. 
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To change the value of a template property—in other words, to edit the property of 
an editable tag—select its name from the list and fi ll out the option that appears at 
the bottom of the window. For example, in the case of color properties, use the color 
box to pick a Web-compatible color. If the property is a path (like a link or an image’s 
source property indicating the graphic fi le’s location in the site), use the common 
folder icon to browse to select the fi le. 

Once you’ve fi nished setting the editable properties for the page, click OK to close 
the window.

Hiding and Showing Optional Regions
As with Editable Tag Attributes, you use the Template Properties window to control 
the display of optional regions. On template-based pages, you can show or hide an 
optional region by choosing Modify→Template Properties to open this dialog box 
(see Figure 18-17). Next, select the name of the optional region. To make all page 
elements in the region appear, turn on the “Show” checkbox at the bottom of the 
window. To hide the optional region, deselect this box.

Applying a Template to a Page You Already Made
What happens if you create a Web page and then decide you want it to share the look 
of a template? No problem. Dreamweaver lets you apply a template to any Web page 
in your site, as long as that page isn’t already based on a template. 

To apply a template to a page you’ve already created:

 1. Choose File→Open to open the page you want to alter.

The Web page opens.

 2. Choose Window→Assets. Click the Asset panel’s Templates button (see Figure 
18-4).

The Assets panel appears and reveals a list of the site’s templates.

Figure 18-17:
A Template property for an optional 
region has either a value of true or false. 
True means the contents of the region will 
be visible on the page, while false hides 
the region. (The “Allow Nested Templates 
to Control This” option is described in the 
box on the facing page.)
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Tip: You can also apply a template to a page by choosing Modify→Templates→Apply Template to Page. 
Select the name of the template from the window that appears and skip to step 5.

 3. Click a template in the list on the Assets panel, and then click Apply.

The Inconsistent Region Names dialog box opens (Figure 18-18). 

 4. In the list under Editable Regions, choose Document Body.

To the right, in the Resolved column, you’ll see <Not Resolved>. This is Dream-
weaver’s way of saying it doesn’t know what to do with the contents of the current 
page. You need to pick one of the template’s editable regions.

 5. From the Move Content to New Region menu, select an editable region. 

If you want to keep the material, select the name of an editable region from the 
list; otherwise, choose Nowhere, which, in effect, creates a new blank page based 
on the template. 

Controlling the Nest
The Template Properties dialog box includes a checkbox 
labeled “Allow Nested Templates to Control This.” What 
does it do?

Imagine that you create a template and add several optional 
regions and editable tag attributes to it. You then use this 
template as a basic design for more refi ned templates for 
each section of your site. When you create one of these 
nested templates based on the master template, it has access 
to the Template Properties window, where page authors 
can modify any of the template properties created by the 
original, master template. 

For example, to better identify each section of a site, you 
might add a different background color to each section’s 
pages: blue for the products section, orange for the sup-
port section, and so on. In the master template, you make 
the <body> tag’s Bgcolor property editable. Now, when 
you create a nested template for the products section, you 
simply open the Template Properties dialog box and set 
the property to the blue color you desire. For the support 
section’s nested template, set the property to orange. Now 
when you create a template-based page for the support 
section, its background will be orange, while a page for the 
products section will have a blue background.

However, to let your site’s color palette go really wild, you 
might want every page in the site to have its own unique 
background color. (Disclaimer: Don’t try this at home.) In 
this case, you’d want to let every page based on a nested 
template have an editable Bgcolor property. 

To do so, open the nested template, open the Template Prop-
erties window, select the property that should be editable in 
pages built from this template (color in this case), and turn 
on the “Allow Nested Templates to Control This,” checkbox. 
Now this property is uneditable in the nested template, but 
editable in all pages created from it.

You’ve probably realized by now that the phrase “Allow 
Nested Templates to Control This” doesn’t make much sense. 
Turning it on actually prevents the nested template from 
controlling the property. A better way to think of it is “Allow 
pages created from this template to control this property.” 

The bottom line: Turning on this box makes the attribute 
uneditable on that page. If it’s a nested template, it lets the 
Template property “pass through” to all pages based on this 
template. In other words, you can’t set the background color 
in the template, but page authors can change it in pages 
created from the template. 

FREQUENTLY ASKED QUESTION
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Unfortunately, you can only select a single editable region. If several content regions 
are in the original, Dreamweaver merges them all into a single editable region. 

 6. If Document Head also appears in the window, select it and choose “head” from 
the Move Content to New Region menu.

Doing so will preserve any special information you added to the head of your page, 
like Cascading Style Sheets, meta tags, custom JavaScript programs, and other 
information that goes in the <head> of the document. Unfortunately, the title of 
your original page is always replaced with the default title of the template. You’ll 
have to reenter the title (see page 15) after you apply the template. 

Caution: If you apply a template to a page that has Dreamweaver Behaviors (Chapter 12) applied to it, be 
careful when selecting this option. If the same behaviors already exist in the template code, Dreamweaver 
actually makes a duplicate copy of the JavaScript code in the <head> of the page. To get rid of the extra 
code, you’ll need to go into Code view (Chapter 10) and manually remove it. 

 7. Click OK.

Your new page appears.

Update a Template
Templates aren’t just useful for building pages rapidly; they also make quick work of 
site updates. Pages created from templates maintain a link to the original template 
fi le; you can automatically pass changes to a template along to every page built from 
it. If you used templates to build your site, you probably won’t cry on your keyboard 
when the boss says you must add an additional button and link to the navigation 

Figure 18-18:
When you apply a 
template to a page 
you’ve already created, 
you must tell Dream-
weaver what to do 
with the material that’s 
already on the page. Do 
so by selecting one of 
the template’s editable 
regions from a pop-up 
menu, which will take 
charge of all editable 
regions in your page.
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bar. Instead of editing every page, you can simply open the template fi le, update the 
navigation bar, and let Dreamweaver apply the update to all the pages.

You update a template (and all the pages based on it) like this:

 1. Choose Window→Assets.

The Assets panel appears.

 2. Click the Templates button (see Figure 18-4).

A list of the site’s templates appears. 

 3. Double-click the template’s name to open it.

Alternatively, you can select the template in the Assets panel and click the Edit 
button to open the original template (.dwt) fi le (see Figure 18-4).

The template opens.

Tip: You can also open a template by double-clicking the appropriate template (.dwt) fi le located in the 
Templates folder in the Files panel (see page 466.)

 4. Edit the template as you would any Web page.

Since this is the original template fi le, you can edit any of the HTML in the docu-
ment, including Cascading Style Sheets, meta tags, timelines, and layers. You can 
also add or remove editable regions (see page 570). 

Take care, however, to edit only the areas that you did not mark as editable regions. 
The reason: When you update your pages, any region marked as editable in a tem-
plate fi le isn’t passed on to pages based on that template. After all, the template is 
only supposed to dictate the design of those pages’ non-editable regions.

Note: Be careful when you remove editable regions from a template. If you’ve already built some pages 
based on the template, Dreamweaver warns you when you save the template. As described below, you 
can either delete the content that was added to that region in each of the pages you created, or move it to 
another editable region in the page. 

 5. Choose File→Save.

If you’ve already created pages based on this template, Dreamweaver opens the 
Update Template Files dialog box. It lists all the fi les that use the template. 

 6. Click Update to update all fi les based on the template.

Dreamweaver automatically applies the changes you made to the pages based on 
the template. Then, the Update Pages dialog box opens and displays a log of all 
changes Dreamweaver made to the fi les in your site.

On a large site, this automatic update feature can be an incredible timesaver, but 
you may not want to click Update, at least not right now. Perhaps you’re just sav-
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ing some of your hard work on the template, but aren’t quite fi nished perfecting 
it—why waste your time updating all those pages more than once? In such a 
scenario, click the Don’t Update button. Remember, you can always update the 
pages later (see the box below).

7.  Click Close.

The Update Pages dialog box closes.

You’ll need to update all your fi les even if you make a simple change to the template, 
like changing its name. 

Updating Nested Templates
When you build a Web site using nested templates, you’ll have multiple templates af-
fecting your pages. The master template controls design elements of a nested template, 
which in turn controls pages based on the nested template. (You can even make nested 
templates out of nested templates, but for sanity’s sake, you’d better not.) With this 
level of complexity, updates to nested templates can get confusing fast. 

In a nutshell, here’s how it works: 

 • If you edit a locked region in a master template and then update your site, not only 
will a nested template update, but so will all pages built from it. 

Wait to Update
Whenever you modify and save a Library item or a template, 
Dreamweaver gives you the option to update any pages 
in the site that are descended from it. Very often, you’ll 
say Yes. 

But there are times when you 
might wait to update the site. If 
you’re making a lot of changes 
to multiple Library items or 
templates, for example, you 
may wish to wait until you’ve 
fi nished all your edits before 
letting the changes ripple 
through your pages. After all, it 
can take some time to update 
large sites with lots of pages. 

Dreamweaver lets you update 
pages that use Library items and templates at any time. 
Just choose Modify→Library→Update Pages or Modify→
Templates→Update Pages. Both menu options open the 

same dialog box. 

At this point, you can update pages that use a specifi c Library 
item or template by choosing Files that Use from the “Look 

in” menu and then selecting 
the appropriate name from 
the pop-up menu. If you want 
to update all pages in the site, 
choose Entire Site, and select 
the name of the local site 
from the pop-up menu. Turn 
on both the “Library items” 
and Templates checkboxes to 
update all pages.

When you click Start, Dream-
weaver does its work, report-
ing the results of the update 

in the Log fi eld at the bottom of the dialog box. If you fi nd 
the log useless, just turn off “Show log” to hide the report. 
Click Close after Dreamweaver fi nishes.

POWER USERS’ CLINIC
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 • If you edit a locked region in a nested template and then update, those changes 
will pass on to pages built from that nested template. 

However, changes you make to an editable region of a master template do not pass on 
to any page. Neither do changes you make in editable regions of a nested template. 

Note: Sometimes after making changes to a master template, Dreamweaver doesn’t update pages based 
on nested templates based on the master template. The surefi re way to verify that all template updates are 
correctly done is to choose Modify→Templates→Update Pages and select the “Entire Site” option.

Unlinking a Page from a Template
If you’re confi dent that you won’t be making any further changes to a page’s tem-
plate, and you’d like to be able to edit the page’s locked regions, you can break the 
link between a page and its template choosing Modify→Templates→Detach from 
Template. 

All of the HTML in the page is now editable, just as on a regular Web page—which 
is what it is. You’ve removed all references to the original template, so changes to the 
template will no longer have any effect on this page.

Note: If you unlink a nested template from its master template, Dreamweaver removes only the code provided 
by the original master template. Any editable regions you added to the nested template remain.

Exporting a Template-Based Site
The good news about Dreamweaver’s sophisticated templating features is that they let 
you build complex Web pages that are easy to create and update. The bad news is that 
some behind-the-scenes code is necessary to achieve this ease of use. Dreamweaver’s 
template features rely on HTML comment tags to identify editable, optional, and 
repeating regions, as well as nested template and editable tag attributes (see the box 
on page 572). Although this code is only for Dreamweaver’s use and has no effect 
on how a Web browser displays the page, it does add a small amount to the size of 
your Web pages. 

Fortunately, Dreamweaver includes a feature that lets you export an entire site into a 
new folder on your computer without any template markup code. It’s a good last step 
before transferring a freshly completed Web site to a Web server. 

 1. Choose Modify→Templates→Export Without Markup.

Dreamweaver MX uses the currently active site, so make sure you’ve got the site you 
wish to export selected in the Files panel (see page 466). The Export Site Without 
Template Markup window appears (see Figure 18-19).

 2. Click the Browse button and select a folder for the exported site.

Select a folder other than the current local site folder. You’ll always want to keep the 
original fi les in the local folder, since they’re the ones that will keep the template 
markup, making future updates possible. 
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 3. Turn on the export options you want.

The Export window includes two options. The fi rst, Keep Template Data Files, cre-
ates an XML fi le for each template-based page. In other words, when you export 
the site, there will be one HTML page (without any special template code) and an 
XML fi le (which includes all the template code as well as the page content). 

Theoretically, you could then go back and choose the File→Import→XML into 
Template to recreate the page, complete with the original template information. 
However, in practice, you probably won’t. For one thing, this process creates lots 
of additional fi les that you wouldn’t want to move to the Web site. Also, when you 
want to work on the site to update and edit it, you should use the original fi les in the 
site’s local folder anyway, since they still have the useful template code in them.

The “Extract only changed fi les” option speeds up the process of exporting a large 
template-based site. It forces Dreamweaver to export only pages that you’ve changed 
since the last export. Unfortunately, it doesn’t tell you which fi les it exported until 
after the fact. So, to make sure you get those newly exported fi les to the Web server, 
you need to keep track of changes by hand.

 4. Click OK to export the site.

Dreamweaver goes through each page of the site, stripping out template code and 
exporting it to the folder you specifi ed.

It’s a fi ne idea to perform an export after you’ve completed your Web site and are 
ready to move it to the Internet. You can then move the lean, clean exported fi les to 
the Web server. 

You can use Dreamweaver’s FTP feature to do the uploading (page 522), but you’ll 
need to create a new site and defi ne the folder with the exported fi les as a local root 
folder. Whenever you need to add or update template-based pages, use the original 
site fi les and then export the changed fi les. You can then switch to the site containing 
the exported fi les and transfer the new or updated fi les to the Web server.

Figure 18-19:
Dreamweaver MX 2004 lets you 
strip out template code from tem-
plate-based pages with the Export 
Site Without Template Markup 
command.
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Template Tutorial
In this tutorial, you’ll create a template for the Horoscopes section of the National 
Exasperater site. Then you’ll build a page based on that template and enjoy an easy 
sitewide update courtesy of Dreamweaver’s templates feature. 

Note: The tutorial in this chapter requires the example fi les from this book’s Web site, www.sawmac.com/
dwmx2004/. Click the Tutorials link to go to the tutorials page. Under “Chapter 18: Templates Tutorial,” click 
Windows or Macintosh to download the fi les, depending on the kind of machine you’re using. 

After your browser downloads and decompresses the fi les, you should have a DWTemp (short for Dream-
weaver Templates) folder on your computer, containing the Web pages and graphics needed for this tutorial. 
If you’re having diffi culties, the Web site contains detailed instructions for downloading the fi les you’ll be 
using with this book.

Creating a Template
This tutorial guides you through the creation of a template, the creation of a page 
based on that template, and then an editing and auto-update procedure. 

These instructions assume that you’ve downloaded the necessary tutorial fi les, as 
described above, and defi ned a site using the DWTemp folder as your local root folder 
(for information on defi ning a site, see page 26).

 1. Open the Site window by pressing the F8 key.

 2. In the Site window, fi nd and double-click the page horoscope.html.

It’s usually easier to start with an already-designed Web page and then save it as 
a template. For the purposes of getting to bed before midnight tonight, pretend 
that you’ve just designed this beautiful, half-fi nished Web page.

 3. Choose File→Save as Template.

The Save as Template dialog box opens.

 4. Name the template Horoscope; click Save. In the Update Links window, click 
Yes.

Behind the scenes, Dreamweaver creates a new folder—Templates—in the site’s 
root folder and saves the fi le as Horoscope.dwt inside it. A new template is born. 
You can see it in the Templates page of the Assets panel, as well as the new folder 
in the Site window. 

The template is a model for other pages. But although they’ll be based on its design, 
they won’t be identical. The next step is to identify those areas of the design that 
will change from page to page—the editable regions. 

 5. Click the gray square labeled sign_image. 

For placement purposes, you’ve put a dummy graphic on the page. When you add 
new horoscopes to the site, you can replace this graphic with a real astrological 
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sign. To make it possible to replace it with a real image in the resulting Web pages, 
you need to mark this graphic as editable, like so:

 6. Choose Insert→Template Objects→Editable Region.

The New Editable Region dialog box appears. Here, as in the following steps, 
you can also choose the Editable Region option from the Templates menu on 
the Common tab of the Insert bar (see Figure 18-2) or press Ctrl+Alt+V (Op-
tion-c-V).

 7. Type signImage; click OK.

A small tab, labeled signImage, appears on the placeholder graphic. There is one 
more thing you’ll want to replace every time you create a Web page based on this 
template: the horoscope text.

 8. Click before the “S” in the heading Sign Goes Here and drag down and to the 
right until you’ve selected the two lines of text. (Don’t select the image with the 
moon that appears below the text.)

At this point, the heading and the paragraph marked “Horoscope goes here” 
should be selected.

 9. Choose Insert→Template Objects→Editable Region; type horoscope; click OK. 

So far you’ve added two editable regions—the most basic type of template region. 
Next, you’ll explore some of the templating features Dreamweaver offers.  

 10. Select the “Sign of the Month” image. 

Of course, only one sign each month can be the Sign of the Month, so you’ll want 
this graphic to appear only on a single page each month. An image like this is the 
perfect opportunity to use an optional region—an area of the page that you can 
hide or show on a page-by-page basis. 

 11. Choose Insert→Template Objects→Optional Region.

The New Optional Region window appears. 

1 2. Type SignOfMonth in the name fi eld, turn off the Show by Default checkbox, 
and click OK.

Since most pages won’t display this graphic, you’ll speed up your work by hiding 
it by default, and making it visible just on the one “Sign of the Month” page. 

Next, you’ll add a repeating region to the box on the right side of the page to ac-
commodate multiple names of “Celebrities who share this sign.” You’ll then make 
the text editable, so that you can type the list of individual celebrity names. 

 13. In the yellow box at the right side of the page, click anywhere inside the text 
“Name goes here.” 

This text is enclosed inside a <div> tag, which is itself wrapped by another <div> 
that has a Cascading Style Sheet class called “celebrity” applied to it (see page 272 
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for more detail on the use of the <div> tag). Each time you want to add a celebrity 
name, you’ll need to duplicate this tag. To do so, turn it into a repeating region:

 14. In the tag selector at the bottom of the window, click the <div.celebrity> tag. 

You’ve just selected the <div> tag and everything inside it. Because the number of 
names may vary from page to page, this is a perfect place for a repeating region. 

 15. Choose Insert→Template Objects→Repeating Region. In the window that ap-
pears, type repeatCelebrity. Click OK.

Dreamweaver inserts a new repeating region with the familiar blue tab. The 
region’s name is “Repeat: repeatCelebrity,” indicating that it isn’t any ordinary 
template region—it’s a repeating region. However, turning a part of the page 
into a repeating region doesn’t automatically make it editable. Since you’ll want 
to edit the text and add new names to each page, you’ll need to add an editable 
region inside this repeating region. 

 16. Select the text “Name goes here,” and choose Insert→Template Objects→Editable 
Region. In the Name fi eld, type celebrity, and click OK.

Another blue tab, labeled “celebrity” appears inside the repeating region. On 
template-based pages, you’ll now be able to change this text, plus add additional 
celebrity names easily. There’s one last item for this page—the ad. The current ad 
you see is just a placeholder. Because all ads that go in that location are the same 
size and require the same formatting, you don’t need to make the entire graphic 
editable. You’ll use Dreamweaver’s Editable Tag Attribute feature instead.

 17. At the left side of the page, click the graphic labeled Dummy Ad. Choose Modify→
Templates→Make Attribute Editable.

The Editable Tag Attributes window appears. 

 18. Choose SRC from the Attribute menu. Turn on “Make attribute editable.”

The other fi elds in the window become active (see Figure 18-20). 

 19. In the label fi eld, type adSrc. Choose URL from the Type menu, and leave the 
default value as it is.

The window should look like Figure 18-20. The label helps you identify which 
property of which page element you’re editing. URL in the Type menu informs 
Dreamweaver that this attribute is a path, enabling Dreamweaver’s site manage-
ment tools to accurately update links and paths to graphics fi les as you move 
template-based pages around your site.

 20. Click OK to close the window.

The graphic suddenly changes into Dreamweaver’s broken-image icon. Don’t 
worry; everything is just fi ne, as you’ll see in the next section. (Note that in the 
real world, you’d also want to make the image’s Alt property editable as well, so 
that you can add different alternate text for each ad on each page.)

Template Tutorial
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 21. Choose File→Save. 

Dreamweaver pops up an annoying message informing you that the editable re-
gion signImage (the region containing the gray placeholder graphic for each sign’s 
astrological symbol) is inside a <p> tag, and that anyone who uses this template 
won’t be able to create new paragraphs. When building a page from this template, 
page authors can only change this image; they can’t delete the image and, say, type 
a 40-page treatise instead (thank goodness!). This irritating error is Dreamweaver’s 
way of “helping” by pointing out what must be an error on your part. 

 22. Click OK to close the dialog box. Close this fi le.

Congratulations! You’ve created your fi rst template. 

Creating a Page Based on a Template
Now it’s time to get down to business and build Web pages. Look at the Site menu 
and make sure you’ve selected the site that you defi ned in step 1 at the beginning of 
this tutorial (page 601). Then proceed as follows:

 1. Choose File→New.

The New Document window opens. 

 2. Click the Templates tab.

A list of all defi ned sites appears in the “Templates for” box at left. 

 3. Make sure the site you defi ned for this tutorial is selected; also make sure the 
“Update page when template changes” checkbox is turned on.

If you don’t turn on the “Update page” box, the new page won’t link to the original 
template fi le—and won’t update when you make changes to the template.

 4. Select Horoscope from the templates list and click Create.

Figure 18-20:
The Editable Tag Attributes window lets you make 
a specifi c property of a selected tag editable on 
template-based pages.
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And lo, a new, untitled Web page document appears, one that looks (almost) 
exactly like the template (Figure 18-21).

 5. Choose File→Save. Save the fi le as gemini.html in the DWTemp→horoscopes 
folder.

To indicate that it’s the offspring of your template, the document window has a 
yellow tab in the upper-right corner that reads Template: Horoscope. You can see 
your editable and repeating regions indicated by blue tabs.

 6. Make sure the document window’s toolbar is visible (by choosing View→Tool-
bars→Document); type Gemini into the Title fi eld.

You’ve just named your page, saving you from the ignominy of showing up in 
search engines as “Untitled.” Next stop: Replacing the dummy astrological sign 
image with a real one.

 7. Click the gray “sign_image” box to select it. Press the Delete or Backspace key.

It’s useful to include placeholders for your text and graphics, like this image place-
holder, in your templates, to give your page shape and make clear what the content 
should look like. You’ll now replace this placeholder with a Gemini sign image.

 8. Insert the Gemini image.

Choose Insert→Image, for example. Navigate to the DWTemp→images_global→
horoscope folder; double-click the fi le called gemini.gif. When you return to your 
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Figure 18-21:
In template-based 
pages, blue tabs identify 
editable areas of the 
page, and a yellow tab 
appears at top right. 
Notice that the repeating 
region has small control 
buttons (+, -, and up 
and down arrows) and 
the optional region—the 
moon graphic—is invis-
ible. (Remember, you 
deselected the “Show by 
Default” option for this 
graphic.)
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document, you’ll discover that Dreamweaver has replaced the placeholder image 
with the sign’s “twins” astrological symbol.

Now you’ll add a proper horoscope.

 9. Select the words Sign Goes Here, and type Gemini.

You also want to add Gemini’s unfortunate astrological forecast.

 10. Select the text “Horoscope goes here” and type the following:

You’ll wish you had a twin this month. Then at least there’d be someone else to blame 
for your problems and share your woes. Ever thought about moving? Good, ’cause 
now’s the time: You’re being evicted on the 16th. 

Oh, well…there’ll be other months for Gemini. However, it just so happens that 
Gemini is the “Sign of the Month.” (Remember the optional region you created 
for this graphic in the previous tutorial?) It isn’t currently displayed because you 
turned it off. In the next step, you’ll magically make it reappear.

 11. Choose Modify→Template Properties.

The Template Properties window appears (see Figure 18-22). There are two items 
listed: The fi rst is the editable tag attribute for the banner ad, and the second is 
the optional region you wish to make visible.

1 2.  In the properties list, select “signOfMonth” and turn on the “Show signOfMonth” 
checkbox.

The optional region is now visible on the page. While you’re here, you may as well 
also add a real ad to the page.

 13. Select “adSrc” in the Template Properties window. Click the Folder icon at the bot-
tom of the window. Browse to and select the fi le alien_ad.gif in the ads folder. 

Template Tutorial

Figure 18-22:
The Template Properties window does 
double duty. Not only does it let you 
hide or show optional regions, but it’s 
also the place to set values for edit-
able tag attributes.
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As when selecting any fi le in Dreamweaver, the helpful “select fi le” button makes 
supplying the proper path to a fi le a snap.

 14. Click OK to close the window.

The red “Sign of the Month” button appears, as does an ad for the amazing and 
historically accurate video, Alien Autopsy 7. You’re nearly done building this 
new page. The last task is adding a list of celebrities who share this unfortunate 
horoscope. 

Note: This tutorial would like to apologize to those who have a true belief in and understanding of the 
zodiac. The astrological predictions included herein are purely fi ctitious and intended for entertainment 
purposes only.

 15. At the bottom of the page, click the blue tab labeled “celebrity.”

You’ve just selected the text in that editable region.

 16. Type Mike Myers.

There are a lot of Gemini celebrities out there. Fortunately, you can add more 
entries using the repeating region controls.

 17. Click the + button just to the right of the blue Repeat:RepeatCelebrity tab.

You’ve added another row to the page, as shown in Figure 18-23.

Note: If a page has a lot of elements crowded together—tables, images, text—Dreamweaver sometimes can’t 
display the small buttons that let you add and remove repeating entries. In this case, you can also use the 
Modify menu. Click inside a repeating region and choose Modify→Templates→Repeating Entries and select 
an action from the submenu, such as New Entry After Selection, to add another editable entry.

 18. Click the blue tab of the newly added “celebrity” editable region and type Angelina 
Jolie.

For now, you’ll add just one more celebrity to the list, though you can actually 
add as many as you want. 
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Figure 18-23:
The control buttons to the right of repeating regions (circled 
in this picture) let you add, remove, and rearrange repeating 
entries. In this example, clicking the + button adds another table 
row for adding an additional celebrity name.
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19.  Repeat steps 17 and 18 to add one last celebrity name: Son of Bigfoot.

But since Son of Bigfoot is a corporate spokesperson for the National Exasperater, 
he’d better get top billing.

 20. Select “Son of Bigfoot” (either select the text, or click the blue tab above the 
name), and twice click the up arrow button next to the repeating region.

The up and down arrows (Figure 18-23) let you move a repeated region above or 
below other repeated regions.

OK. Gemini’s received enough bad news for one month. This page is done.

 21. Choose File→Save and then close the gemini.html document window.

Congratulations! You’ve just created your fi rst page based on a template. You 
could, of course, continue in this manner, building page after page based on this 
template. 

Updating a Template
Now the fun begins. Remember, this page maintains a reference to the original 
template. In the fi nal phase, you’re going to make a few changes to the template. 
Choose Window→Assets to open the Assets panel, and click the Template button 
to reveal the templates for this site (see Figure 18-4).

 1. In the Assets panel, double-click the Horoscope template to open it.

The original template—the Horoscope.dwt fi le—opens. It would be nice to add 
a navigation bar to the left side of this page, so that visitors can quickly jump to a 
particular horoscope. Fortunately, there’s a Library item already created for doing 
so. (See Chapter 17 for more on Dreamweaver’s Library tool.)

 2. Click the Library icon in the Assets panel (directly below the Template icon).

There’s one Library item listed: Horoscope Nav.

 3. Drag the Library item from the Assets panel and drop it into the empty space just 
above the broken-image icon for the ad on the left edge of the template. 

Alternatively, you can click inside this area in the document window, select the 
Library item in the Assets panel and then click the Insert button at the bottom of 
the Assets panel. Either way, a fresh new navigation system appears on the page. 

It would also be nice if the “Sign of the Month” graphic were a little more promi-
nent; inside the box on the right side of the page, for example.

 4. Click the blue tab labeled “If Sign of Month.” 

You’ve just selected the optional region you created earlier. Now you need to move 
it to the box on the right side of the page.

 5. Remove the region from the page by choosing Edit→Cut. 

Template Tutorial



 chapter 18: templates 609

Don’t worry—you’ll add it back next. What you really want to do is place it at 
the top of the box, before the astrological symbol for the particular sign. The tag 
selector will make your task easier.

 6. Click just below the top of the yellow box and to the left of the “sign image” 
region.

The cursor is now just to the left of the sign image, but not at the top of the box. 
At this point, you need to know a little bit about the HTML code used here; the 
placeholder graphic is actually inside of a paragraph tag. To put the “Sign of the 
Month” optional region above it, you need to place the cursor before this paragraph. 
Unfortunately, you can’t do it by clicking in the document window, but you can 
use the tag selector to help you. 

 7. Click the <p> tag in the tag selector at the bottom of the document window and 
press your keyboard’s left arrow key. 

Now you’re probably thinking, “But everything looks the same!” After all, the cur-
sor still appears just to the left of the image. 
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Figure 18-24:
The fi nished tutorial 
page complete with ad, 
horoscope, and “Sign 
of the Month” logo. 
Feel free to compare 
the results of your work 
with the professionally 
completed version at 
www.sawmac.com/
dwmx2004/tutorials/.
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However, even though Dreamweaver doesn’t show it, you’ve just moved the cursor 
to the outside of the <p> tag. You’ve just learned one of the most valuable tips for 
using Dreamweaver to edit HTML code. If you understand your code, you can 
navigate around it easily using the tag selector and your keyboard’s arrow keys. 

 8. Choose Edit→Paste.

Dreamweaver drops the optional region into its new location.

 9. Choose File→Save.

Once again that annoying message appears (see step 21 on page 604); just click 
OK. The Update Template Pages dialog box appears, listing all of the pages in the 
site based on this template (in this case, just the lone gemini.html fi le).

 10. Click Update.

Dreamweaver opens the Update Pages dialog box and updates the appropriate 
Web pages, adding the new sidebar navigation and emoticons to each one. In 
this case, you based only one page on the template, so Dreamweaver updates 
only one page—as indicated by the list of changes Dreamweaver shows when it’s 
fi nished. 

 11. Click Close to close the Update Pages dialog box. Finally, open the fi le gemini.
html, and press F12 to preview it in a Web browser.

Notice that the horoscope navigation bar now appears in the gemini.html docu-
ment and the “Sign of the Month” graphic has moved. (Figure 18-24). This series 
of events happened because you changed the template to which the page was 
genetically linked. Ah, the power!
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