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Defining the Site

In each new chapter, I request that you copy files from the H•O•T CD-ROM to a folder on your hard
drive. In this exercise, you will revisit how to define a site based on the contents of the folder. Because
each chapter of this book features different files, each chapter is defined as its own distinct site, so
you will go through the process of this exercise many times. Normally, if you were working on a single
site, you would most likely define your site once. If you switched projects, however, you would need to
define a new site. Dreamweaver MX 2004 allows you to manage multiple sites, which is helpful if you
have multiple clients or projects for which you plan to use the program.

1.

1. Copy the chap_04 folder from the H•O•T CD-ROM to your hard drive.

2. Choose Site > Manage Sites to open the Manage Sites window. This window lets 
you add new sites, edit and make duplicates of existing sites, export and import sites, and
remove sites.

3. Click the New button, and from the small drop-down menu, choose Site, which will open
the Site Definition window.

Note: The FTP & RDS Server option involves more advanced workflow and will not be
covered in this book.
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4. Make sure the Basic tab, in the upper-left corner, is selected. In the What would you like to name
your site? text field, type Chapter 4. This defines the name for your site. This name is an internal nam-
ing convention used by Dreamweaver MX 2004. I suggest you give each site a name that is relevant to
you. You can use any name you want, including special characters, such as spaces, dashes, and so on.
Click Next.
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5. Make sure the No, I do not want to use a server technology radio button is selected. This tells
Dreamweaver MX 2004 you are creating a static Web site and are not going to use a server technology,
such as ASP or CFM, with your site. A server technology is necessary if you are creating a Web site
that connects to a database to generate dynamic data. Click Next.

Don’t worry if you change your mind later. You can change all of the settings you define for your site
at a later date. Phew!
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6. Make sure the Edit local copies on my machine, then upload to server when ready
(recommended) radio button is selected. This tells Dreamweaver MX 2004 that you want 
to create the Web pages on your computer and upload them when you are ready. This is 
the most common way to create and publish Web pages.

7. Click the small folder icon to open the Browse dialog box. Locate the chap_04 folder on 
your Desktop:

• Mac: Highlight the chap_04 folder and click Choose.

• Windows: Double-click the chap_04 folder to open it. Click Open.

This specifies the folder you want to use as the local root folder for your site. In this case, you are
using the chap_04 folder as the local root folder. Each site you define in Dreamweaver MX 2004 
must point to a folder that you are using as the local root folder. Click Next.
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8. Make sure the How do you connect to your remove server? option is set to None. You will learn
more about connecting to a remote Web server and how to upload files later in Chapter 20, “Getting 
It Online.” Click Next.
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9. The next screen displays a summary of the settings you have specified for this site. Take a moment
to review the information on this screen. If you have made a mistake, you can click Back to return to
any of the previous screens to make any needed changes. Click Done if everything looks okay.
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NOTE | Basic and Advanced Tabs

You might have noticed that the Site Definition window contains two tabs: Basic and Advanced.
These tabs serve the same purpose: They both let you define a site. The Basic tab is more of a
wizard approach, where you define a site by answering a series of questions. This is a great place
to start if you are new to Dreamweaver MX 2004. The Advanced tab is where more experienced
Dreamweaver MX 2004 users will go to define a site. The Advanced tab gives you direct access
to all the options necessary to define a site and work with other site features, such as Design
Notes, modifying the Site Map Layout options, and changing the Site panel column options. 
As you become more experienced with Dreamweaver MX 2004, you will find yourself using the
Advanced tab to define your sites.
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Creating and Saving a New Document

This next exercise teaches you how to create and save a document in Dreamweaver MX 2004. You will
be saving this document as index.html, which has special significance in HTML, and almost always
means that it is the beginning page of a site. Additionally, you will learn to set the title of this document
to Welcome to laEyeworks.

2.

1. If a blank document window is already open, close it and don’t save any changes if you
are prompted. Each time you open Dreamweaver MX 2004, by default it will open to the start
page, which lets you create a wide variety of documents by simply clicking on a link. (You can
disable the start page in the preferences, which is explained in Chapter 2, “Interface.”)

The start page is a quick and easy way to create new documents. However, it does not give
you access to all of the new page templates inside Dreamweaver MX 2004 or let you control
some other options, such as creating a new page using XHTML instead of HTML. To access
all of the new page templates, just follow the next few steps.

2. Select File > New. This will open the New Document dialog box, which lets you choose 
a template for your new document.
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3. Make sure the Basic page category is selected and then choose HTML under the Basic page
section. This tells Dreamweaver MX 2004 that you want to create an HTML page. Click the Make
document XHTML compliant check box to create a new page with XHTML instead of HTML. 
Click Create.

Only the new document window gives you the ability to make a new XHTML document; the start
page doesn’t offer this option. Sure, you can convert your HTML documents in XHTML later (you will
learn how to do this in Chapter 12, “XHTML”), but why not do it the correct way right from the start? 
A quicker way to create XHTML pages would be to change the General preferences in Dreamweaver
MX 2004 so it generates XHTML for all new pages. All you have to do is click a single check box. ;-)
Hey, if you don’t want to use XHTML, that’s fine with me. There aren’t any XHTML police around, but
I strongly recommend that you do because it is the current Web standard for creating Web pages
and will work fine in older browsers.
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NOTE | The New Document Dialog Box

The New Document dialog box gives you access to many templates that you can use for creating
new pages in Dreamweaver MX 2004. These templates are designed to give you the necessary
code to begin creating pages for specific purposes. Within each category are a number of different
template options. For example, within the Framesets category are a number of different frameset
designs. All of the templates are designed to save you time and get you started in the right direction.
Some categories have a check box that will make sure the code is XHTML-compliant. The Templates
tab at the top is reserved for templates that you will learn how to create later in Chapter 17,
“Templates/Libraries.”
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The New Document window will close, and a new blank XHTML document window will open. My
window is currently maximized to its largest size; that’s why I have a little tab in the upper-left corner.
If your window isn’t maximized, or you’re on a Mac using Dreamweaver MX 2004, then you won’t
have this cute little tab.

4. Click the Code button in the Document toolbar to change the view of the page to Code view. 
(If your Document toolbar isn’t visible, select View > Toolbars > Document to make it visible.)

As you probably guessed, the Code view displays only the code of your page. Some people find
looking at all this code kind of difficult or downright scary. Well, if you want to be a professional 
Web designer/developer, you really need to know code and feel comfortable working with it, and 
not limit yourself to just the visual editing environment of Dreamweaver MX 2004. Consider this
lesson “Code 101.”
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When the window is not maximized, you will see (XHTML) in its title bar. This is yet another way to
tell you are working with an XHTML document. The code in lines 1 through 3 tell the Web browser
(and the rest of the curious world) that this page is an XHTML page and not an HTML page. As long
as you see this code, you can be assured that your page is considered a true XHTML page.

5. Click the Design button in the Document toolbar to return to the default Design view of your page.

6. In the Document toolbar’s Title text field, type Welcome to laEyeworks. Press Enter (Windows) 
or Return (Mac). This will define the page title for this page. The page title appears at the top of the
browser when the page is being viewed and is the name used by browsers and Web pages when this
page is bookmarked. Right now the page is blank, but you’re going to turn it into a cool and functional
Web page in a jiffy.

Before you go on, it is very important that you save your file first. All of the site management benefits
introduced in the last exercise depend on Dreamweaver MX 2004 knowing the name of your file.
Because of this, the program constantly notifies you if you are working on an unsaved document.
Besides, no one wants to unexpectedly lose work, and this practice is good insurance against system
crashes and/or a power outage. Anytime you see an asterisk (*) next to the file name of the page,
you know that you have made changes to your page that have not been saved yet!
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7. Save the file as index.html inside the chap_04 folder on your hard disk. Leave this file open—you
will be using it in the next exercise.

There are two names in the title bar of your document panel. The first is the title of the document
(Welcome to laEyeworks). The second name is the file name (index.htm), which shows up to the
right of the title. The title can be different from the file name, as in this example.

File Names versus Titles

As you create Web pages with Dreamweaver MX 2004, you will need to specify various names
for your files, folders, sites, and so on. This might not seem tricky at first glance, but two different
names are actually associated with HTML files: the file name and the title.

When you save a document, you will be assigning its file name. The file name must always end
with the .htm or .html extension. The other name associated with the document is called the title.
The file index.html here, for example, has been assigned the title “Welcome to laEyeworks.”

It is essential that file names do not contain spaces or special characters. Page titles, however,
are much more flexible, and you should make them more descriptive than the file name. When the
page is viewed from a Web browser, the title will be much more visible to your end user than the
file name. Also, when end users bookmark this page, the title will appear in their bookmark lists.
When search engines index the page, it is often categorized by page title as well.
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The Significance of index.html
You just created a document called index.html. What you may or may not appreciate is that this
particular file name has special significance. Most Web servers recognize the index.htm (or index.html)
as the default home page. You can use .htm and .html interchangeably; both will be recognized by the
Web server as HTML pages. If you type the URL http://www.lynda.com, for example, what you will
really see is http://www.lynda.com/index.html, even though you didn’t type it that way. The Web
server knows to open the index.html file automatically without requiring the full URL to be typed.
Therefore, if you name the opening page of your Web site with the file name index.html, the Web
server will know to automatically display this file first.

Taking this concept one step further, you can have an opening page for each section of your Web site,
not just for your home page. This feature has definite advantages—among them, your users won’t find
themselves looking at a generic index, like in the following screen shot.

If you do not have an index.html file in your site, browsers will display a general list of your files,
such as this example.

This is why the file name index.html is so significant. It’s also the reason most professional Web
developers use it as the root file name, although on some servers a different name is used, such as
default.html. What you may not realize is that you are not limited to just one index.html on your site. You
can have an index.html inside each folder that represents a category for your site, such as Company,
Services, Store, and Products.
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Inserting Images

In this exercise, you will continue working with the index.html file and learn to insert images for your
page’s headline, logo, and navigation buttons.

3.

1. Make sure the Assets panel is open by choosing Window > Assets or by pressing F11.

Inserting images from the Assets panel ensures that you are working only with images 
from within your local root folder. This is a good thing, because inserting images from
outside your local root folder will cause problems when you try to upload your page to 
the Web server.
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Working with the Assets Panel

The Assets panel is an incredibly powerful and useful feature in Dreamweaver MX 2004 and is
one of the panels you will use most often. This panel maintains a listing of all the asset types
(images, colors, links, movies, scripts, library items, and templates) within the current local root
folder. Each type of asset is separated into its own category so you can easily and quickly find
what you are looking for. You can even designate an asset as a “favorite,” which places that asset
in the “favorites” group, which is a customized asset group that contains items you use most often.
This is a really powerful feature when you have hundreds or thousands of assets within your local
root folder. That might sound like a lot of assets, but you will be surprised how quickly all those
items add up!

The Assets panel is really small by default and some of its features are hidden from view. In these
images, you can see that the Images group contains information about the file size, type, and path
of the various images listed in this group. Each asset group has different columns that relate to
that specific asset type. By default, the assets are listed in alphabetic order from A–Z. You can
reverse this by clicking on the Name column at the top. In fact, all of the columns can be arranged
in ascending or descending order by clicking on the column name—another handy-dandy feature 
of the Assets panel. ;-)
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Working with the Assets Panel continued

The Assets panel options menu lets you easily copy assets between the various sites that you
have defined. You can also refresh the listing, which is sometimes helpful when you add new
assets to a site and Dreamweaver MX 2004 is already open.
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2. Within the Assets panel, make sure the Site radio button is selected at the top, then locate and
select the logo3.gif file. Click Insert at the bottom of the Assets panel. This will insert the selected
image onto your page.

3. In the document window, click to the right of the header.gif image to deselect it, and press Enter
(Windows) or Return (Mac) to create a paragraph break, causing a space to form between the headline
graphic and the next image.

4. Within the Assets panel, select the glasses2.jpg file. Click Insert at the bottom of the Assets
panel. This will insert the selected image onto your page.
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5. Click to the right of the image to deselect it, and then press Enter (Windows) or Return (Mac). This
inserts another paragraph break between this image and the next, which creates an extra line between
the two images.

6. Within the Assets panel, select the home.gif file. Click Insert at the bottom of the Assets panel.

7. Within the Assets panel, select the about.gif file. Click Insert at the bottom of the Assets panel.

8. Within the Assets panel, select the frames.gif file. Click Insert at the bottom of the Assets panel.

9. Within the Assets panel, select the locations.gif file. Click Insert at the bottom of the Assets panel.

10. Within the Assets panel, select the contact.gif file. Click Insert at the bottom of the Assets panel.

This is what your page should look like at this point.
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11. Click the Code button to see the Code view for this page. Even though you’ve added only a few
images to the page, you can see that quite a bit of code is needed to make this happen.

I strongly suggest that you get into the habit of looking at the Code view of your page as often as
possible. It’s a great way to make yourself feel more comfortable with what goes on behind the
scenes. Note: If your code doesn’t wrap to fit inside the document window, you can make it do this
by choosing View > Code View Options > Word Wrap. Click the Design button (located to the right
of the Code button) to return to the Design view of your page.

12. Save your file and leave it open for the next exercise.

4.Basics | Dreamweaver MX 2004 H•O•T

This code was added
automatically by
Dreamweaver to 
create the page



| 99 |

TIP | Other Ways to Insert Images

There are many ways to insert images in Dreamweaver MX 2004. In this exercise, you learned
how to use the Assets panel to insert images onto your page. I think this is not only the quickest
way, but also the safest way to insert images onto your page. Why? First, only images within your
local root folder are listed in the Assets panel. Second, by inserting images from within your local
root folder, you ensure that the proper paths will be created, so everything works when you upload
your page to a remote Web server. But the Assets panel isn’t the only way to insert images in
Dreamweaver MX 2004. Here are five ways to insert images:

• Select Insert > Image.

• Click the Image button in the Insert panel.

• Press Ctrl+Alt+I (Windows) or Cmd+Option+I (Mac).

• Click and drag from the Assets panel onto the page.

• Click and drag from the Files panel onto the page.

As you become more comfortable with Dreamweaver MX 2004, you should use the method that
feels most comfortable.
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Inserting Text

Adding text to your Web page is simple in Dreamweaver MX 2004. Just like with your favorite word
processor, you can simply start typing text on your page and the text will appear.

In this exercise, you will add some text at the bottom of your page as an alternate navigation system,
which is useful to users who might have images turned off in their browser settings or to those who
are browsing in a nongraphical browser (such as those used by sight-impaired audiences).

4.

1. Click to the right of the contact.gif file you inserted in the last exercise and press Enter
(Windows) or Return (Mac) to create a paragraph break. Type home, press the spacebar, press
Shift+backslash to insert a small vertical line (|), or “pipe,” and press the spacebar again.

2. Type about us, press the spacebar, press Shift+backslash to insert a pipe, and press
the spacebar again.

3. Type frames, press the spacebar, press Shift+backslash to insert a pipe, and press the
spacebar again.

4. Type locations, press the spacebar, press Shift+backslash to insert a pipe, and press
the spacebar again.

4.Basics | Dreamweaver MX 2004 H•O•T

This vertical line is commonly known as a “pipe.” Go figure!



| 101 |

5. Type contact.

6. Press Shift+Enter (Windows) or Shift+Return (Mac) to create a line break. This puts your type-
insertion cursor on the next line without introducing a two-line paragraph return.

7. Type be sure to visit the real laeyeworks.com site.

This is what your page should look like now.

8. Save your file.
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NOTE | Paragraph versus Line Breaks

You may have noticed that each time you pressed Enter (Windows) or Return (Mac), Dreamweaver
MX 2004 skipped down the page two lines. Pressing this key inserts a single paragraph break
(one line of blank space between paragraphs). The HTML tag for a paragraph break is <p>. This
is useful when you want to increase the space between different paragraphs. However, there will
be times when you just want to go to one line directly below the one you are working on without
introducing extra space. Pressing Shift+Enter (Windows) or Shift+Return (Mac) inserts a line
break instead. The HTML tag for a line break is <br>. Knowing the difference between a <p> and
a <br> will allow you to control the spacing between lines of text. You will learn to do this in
Chapter 12, “XHTML.”

The paragraph tag <p> will enter an extra blank line between the closing paragraph tag </p> and
the next line of content. The line break tag <br> will place content on the very next line. You can
see both of these here.
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NOTE | Paragraph versus Line Breaks continued

This is what the closing paragraph tag </p> and the line break <br /> tag look like in the XHTML
code. Note: If your screen looks different from mine, that’s because I changed a setting in the
Code View panel called Word Wrap.
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Centering Images and Text

Now that you have added the images and text to your page, it’s time to learn how to center them. This
section shows you how to use centering procedures with text and images. Keep in mind that this is the
first alignment technique you are learning and you will learn many other alignment techniques through-
out this book.

5.

1. Select the laEyeworks logo image from the previous exercise (logo3.gif) at the top of 
the screen.

2. Click the Align Center button in the Properties inspector. This will snap the logo to the
center of the screen.

3. Hold down the Shift key and click on the remaining images on the page. Still holding
down the Shift key, select the text at the bottom of the screen. Holding down the Shift key
allows you to select multiple items at once.

4. Click the Align Center button in the Properties inspector.

Your page should look like this at the end of the exercise.
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5. Click the Code button in the Document toolbar to see the code for this page. Notice that a bunch
of <align=”center”> attributes were added to various tags in order to center the images and text
elements on the page.

Although this method of controlling Web page layout is somewhat outdated, it is a great example 
of how a few tags can drastically change the appearance of a page. 

6. Save the file and leave it open for the next exercise.
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Modifying Page Properties

This exercise walks you through changing the colors of your page, using the Page Properties panel. The
Page Properties feature controls many important attributes of your page, including the document title
(which you learned about in Exercise 2), margin settings, and the colors you set for your text and links.

The Page Properties window has two modes: HTML/XHTML mode and CSS mode. By default,
Dreamweaver MX 2004 is set up to use CSS to define the properties of each page you create.
Depending on your needs, this may or may not be appropriate. Although I am a huge proponent 
of using CSS, especially for setting page properties, I do realize that it may not be what everyone
needs. So, in this exercise you will learn how to use HTML/XHTML to define the page properties, 
and later in Chapter 9, “Cascading Style Sheets,” you will learn how to use CSS to define the page
properties. How do you like that deal? ;-)

6.

1. Select Edit > Preferences to open the Preferences window. This window contains a bunch
of options that let you modify how Dreamweaver MX 2004 operates and handles certain tasks,
such as using CSS or HTML to set the page properties. You get a chance to work with many of
these preferences as you move through this book, so don’t worry about all of them right now.

2. Make sure the General category is highlighted in the left side of the window. Remove the
check from the Use CSS instead of HTML tags check box. This will force Dreamweaver MX
2004 to use XHTML tags to define the page properties instead of CSS. Notice that by default,
Dreamweaver MX 2004 is set up to use CSS to define the page properties. You will learn more
about the impact this has on your pages in Chapter 9, “Cascading Style Sheets.” Click OK.
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3. Select Modify > Page Properties or use the shortcut—Ctrl+J (Windows) or Cmd+J (Mac)—to
access Page Properties.

4. Move this panel to the side so you can see the Page Properties and your document at the same
time. Click Appearance in the Category pane to make the appearance options available.

This is what the Page Properties window looks like when you use HTML/XHTML to define the various
properties. It looks very different when you use CSS to control the page properties.

5. Click the small box to the right of the word Background. This will open the Dreamweaver MX 2004
color picker.
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6. With your mouse button depressed, move the eye dropper outside of the Page Properties panel
and release the mouse on the background of the home image. This will set the background color of
your page to match the edge of this image. To instantly see the results, click Apply. Don’t click OK yet,
because you still need to set more colors in the upcoming steps.

7. Click inside the text box next to the Text option. Type #FFFFFF. Click Apply. You just colored all
your text white in this document. The Apply button is actually accepting your changes; it is not merely
a preview. Clicking it is the same as clicking OK, except that it does not close the panel.
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To set other colors, you can insert your own values.

8. Type #0000FF for the Links option, which will set the link text in this document to a shade of blue.
Type #9900FF for the Visited links option, which will set visited link text to purple, letting the user know
that that link has already been viewed. If you want, you can set the Active links color to #FFFF00,
which makes the links on the page turn yellow when the mouse is clicked.

9. You could also choose a color by sight, instead of typing in a hexadecimal value. Click the box to
the right of the words Active links and the color picker will open. Move the eye dropper over the
background of the page and click. This will set the active link color to the same color as the back-
ground. The only time an active link color shows is when the mouse button is clicked on the link.

10. Click OK.
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This is what the results of this exercise should look like. You won’t see the link color yet because this
page doesn’t have any links set yet. Oh don’t worry, you will get to do that in the next exercise. ;-)

11. Save the document and leave it open for the next exercise.

NOTE | What Is Browser-Safe/Web-Safe Color?

Browser-safe colors are the 216 colors supported by browsers across platforms (Mac and
Windows). If you use the browser-safe colors inside the Page Properties settings, you reduce the
risk of having your colors shift when people view your Web pages. Frankly, since most computers
have video cards that display millions of colors and ship by default in that mode, you can pretty
much forget about Web-safe colors and work with any color you want. This wasn’t true just a few
years ago, but more and more developers are adopting this practice, and it’s really making the
Web a lot more colorful and interesting.
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HTML/XHTML Page Properties

Category Property Description

General Title The title of your page is what will appear in the title bar of the Web
browser and when your page is bookmarked. This name can contain
as many characters as you want, including special characters, such
as %(#*!.

Encoding Specifies the language for the characters and fonts used in 
the document.

Appearance Background If you want a background image for your Web page, you would 
image specify it here. A background image can be any GIF or JPEG file. If

the image is smaller than the Web browser panel, it will repeat (tile).

Background Sets the background color. The values can be in hexadecimal format
or by name, such as red, white, and so on.

Text Sets the default text color. It can be overwritten for specific areas 
of text.

Links Sets the color for links. This option can be overwritten for specific links.

Visited links A visited link color specifies how the link will appear after a visitor
has clicked it.

Active links The active link color specifies how the link will appear while some-
one clicks it.

Left margin Sets the left margin value in pixels. This attribute is supported only
in Internet Explorer 4.0 or later.

Top margin Sets the top margin value in pixels. This attribute is supported only
in Internet Explorer 4.0 or later.

Margin width Sets the margin width value in pixels. This attribute is supported only
in Netscape Navigator 4.0 or later.

Margin height Sets the margin height value in pixels. This attribute is supported only
in Netscape Navigator 4.0 or later.

Tracing Tracing image Tracing images are used as guides to set up the layout of your page. 
Image They can be any GIF, JPEG, or PNG file.

Transparency Sets the transparency level of your tracing image.

The Page Properties Panel
The Page Properties panel does more than just set the colors of the links and your document title. As 
I mentioned earlier, the Page Properties window has two modes: HTML/XHTML mode and CSS mode.
See the following chart for an explanation of all the HTML/XHTML features. You will learn more about
the CSS Page Properties features in Chapter 9, “Cascading Style Sheets.”



| 112 |

The Dreamweaver MX 2004 Color Pickers
From the Page Properties dialog box, Dreamweaver MX 2004 gives you access to five different color
pickers, from which you can select the colors for your pages. Two of the color pickers, Color Cubes
and Continuous Tone, are browser-safe, and they’re arranged in a manner that makes it easy to select
pleasing color combinations. To understand each function of the color picker drop-down menu, see the
following chart.
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Color preview

Default color System colors

Hex value

Color Picker Options

Option Description

Color preview Gives you a preview of the color that is currently selected or the color that
the eye dropper is picking up.

Hex value Displays the hexadecimal value of the current color or the color that the eye
dropper is picking up.

Default color Removes any colors you have selected. If you do not specify a color in the
Page Properties, the user’s browser will determine what colors are used for
the different text options.

System colors Opens the system color options for your computer—these options will vary
between the Mac and Windows operating systems.

Color options This drop-down menu lets you choose from five different color arrange-
ments. The Color Cubes and Continuous Tone options contain only Web-
safe colors. The Windows and Mac options contain the system colors for the
Windows and Mac operating systems. The Grayscale option contains grays
ranging from black to white.

Snap to Web Safe Automatically switches non-Web-safe colors to their nearest Web-safe values.
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Creating Links with Images and Text

The capability to link to pages and sites is what makes the Web dynamic. This exercise shows you
how to set up links using the Dreamweaver MX 2004 Properties inspector.

7.

1. Select the about.gif (about us) image in the lower-left part of the screen.

2. Click the Browse for File icon, next to the Link option, in the Properties inspector.

Note: If your Properties inspector panel is smaller than what is shown here, click the arrow 
in the lower-right corner to expand it.
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3. Browse to chap_04/aboutus/aboutus.html and click OK (Windows) or Choose (Mac).

Congratulations, you have just created your first relative image link. Why is it relative? It is relative
simply because it linked to a document within this site, not to an external Web site.

4. Highlight the frames.gif (frames) image in the lower-left corner of the screen.

5. Click the Browse for File icon next to the Link option in the Properties inspector.

6. Browse to chap_04/frames/frames.html. Click OK. This image is now linked to the frames.html
page inside the frames folder.

7. Repeat this process for the remaining two navigation icons (locations/locations.html and
contactus/contactus.html, respectively).

You have just successfully added links to the images on this page! If you want to preview the links 
in a browser, press F12 and click any of the images. Note: If a browser does not launch when you
press F12, refer to Chapter 2, “Interface,” to learn how to specify a browser to preview your pages.

Next, you will create some links using text. The process is almost identical, except you will be
selecting text instead of images.
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8. Highlight the words about us in the lower-left corner of the page.

9. Click the Browse for File icon in the Properties inspector.

10. Browse to chap_04/aboutus/aboutus.html. Click OK.

11. Repeat this process for each phrase in the text navigation bar at the bottom of the screen. Be sure
to link the text at the bottom of the page to the same page as the corresponding images.

As you create the text links, you will notice the color of the text change. This happens because you
set the Links color option in the Page Properties to red, and Dreamweaver MX 2004 is previewing
that setting for you.

Dreamweaver MX 2004 H•O•T | 4.Basics



| 116 |

12. Highlight the word laeyeworks.com at the bottom of the page.

13. Type http://www.laeyeworks.com into the Link option in the Properties inspector and press
Enter (Windows) or Return (Mac).

Congratulations, you just created your first absolute link. It’s an absolute link because it begins with
an http header and includes the full address.

14. Save the file. You don’t want to lose any of your work!

15. If you want to preview all of your links, press F12 to launch a browser and try them out.

Note: Only the links you created on the index.html page will be working. You will learn some effective
and fancy ways to work with linking in Chapter 5, “Linking.”
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<meta> Tags

One of the big challenges (aside from building a Web site) is letting the search engines know that your
site exists. There are two steps to getting your site listed: the first is to list it with all the various search
engines out there, and the other is to insert <meta> tags into your HTML so the search engines can find
you on their own and correctly index your site. Many search engines send robots (also called spiders)
out to search the Web for content. When you insert certain <meta> tags into your document, you make
it much easier for the search-engine robots to understand how to categorize your site. This exercise
shows you how to enter <meta> tags with specific attributes, so you can make your Web page more
search-engine friendly.

8.

1. Select Insert > HTML > Head Tags > Keywords. This option opens a small window
where you can enter in the keywords for a particular page. Keywords are words the reflect
the content of a particular page.

2. Type glasses, eyeglasses, sunglasses, frames, los angeles, la, eyeworks. Basically,
you’re listing words that someone might use in a search engine to bring up your site.

3. Click OK.

4. Select Insert > HTML > Head Tags > Description. This option opens a small window
where you can enter in the description for a particular page. The Description is used by
many search engines to describe the contents of a particular page in their listings.
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5. Type Custom high-fashion eyeglasses and sunglasses collections by world renowned designers.

6. Click OK.

7. Click the Code button to view the HTML in this document. See the <meta> information inside the
<head> tag? Visitors to your site won’t be able to see the <meta> tag information because it’s only
visible inside your HTML. It’s a part of authoring the page that has nothing to do with appearance—
and everything to do with helping the search engines find your site.

8. Save and close this document.
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Onward ho! You just built a page, colored it, set links, and added <meta> tags all in one chapter.

WARNING | Keyword and Descriptions

Keywords are <meta> tag values that specify certain words to help Internet search engines index
your site. Many search engines limit the number of keywords you can use. Choose your words
wisely and use no more than 10 to 15 keywords that best describe your site’s contents.

Descriptions are <meta> tag values that also help various search engines index your site. Some
search engines will actually use in their directory the very descriptions you specify to describe
your site. Again, some search engines limit the number of characters indexed, so keep it short
and simple! If you would like more information about <meta> tags, check out these URLs:

Web Developer: META Tag Resources
http://webdeveloper.internet.com/html/html_metatag_res.html

Search Engine Watch
http://searchenginewatch.com/webmasters/meta.html
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