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Intro
This tutorial will help you:

1.	 Define a new Dreamweaver web site

2.	 Create a new HTML file

3.	 Create a new CSS file and attach it to the HTML file

4.	 Create “images” folder and copy image files to it as you go

5.	 Create HTML/CSS layout 

To guide you through the process you will find a screen-shot of every step (even the repetitive once). Each screen shot will 

have a small green arrow ( ) pointing out important section of the screen.

To get started you will need to download “Slices.zip” and extract it somewhere on your hard-drive.

Final result of the tutorial

The result of this tutorial is just the “layout” without any content, or branding.  

Adding and formatting content will be covered in the second tutorial.

http://www.bewebmaster.com/Slices.zip
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Define a Dreamweaver site

1.From the Site menu select New Site 

2. Click the Advance tab 

3. Type in “Dreambig” in the Site name field

4. Click the folder icon next to  Local 

root folder

5. Navigate to a folder on your hard-drive where 

you want to create folder structure for  

“Dreambig” site. In this example the folder  

name is Websites.

6. Click the New Folder icon
New folder iconSome folder on your 
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7. Rename New Folder to Dreambig

8. Double click the  “Dreambig” folder to select  

it and press OK.

9. Press Select
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10. At this point press OK to save your site. In 

later tutorials we will come back here and specify 

remote info to upload the site to the server.
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Create and save a new HTML file

1. Press the HTML button on the welcome 

screen. If you have welcome screen disabled you 

can enable it by going to:

Edit -> Preferences. Click the General category 

and check the box next to “Show Welcome 

screen” option.

2. A blank “untitled” page will load.

3. Go to File menu and select “Save As...” 

option.

4. Save the document as “index” in your 

“Dreambig” site folder. Dreamweaver will  

automatically add .html extension.
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5. Your HTML document is saved and ready to 

be used. 

Note that index.html file is now added to the  

site folder in Dreamweavers’ files panel.

Among other things Files panel is used to  

rename, delete, move or open your site files.
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Create a new CSS file and attach it to the HTML file 
In this section we will achieve following three things by clicking the “New CSS Rule” button in the CSS panel.

1.	 Create a new CSS file

2.	 Attach it to the HTML document

3.	 Define styles for the <body> tag of the page

1. Click the “New CSS Rule” button in the 

CSS panel

2. In the New CSS Rule window make sure Selec-

tor Type is set to Tag, Selector Name to body 

and Rule Definition to (New Style Sheet File) 

and press OK
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3. Dreamweaver will prompt you to save your 

style sheet file.  Save it in your Dreambig 

folder as css_styles. Dreamweaver will add 

.css extension automatically.

4. Specify Type styles as shown in the image. 

Press Apply button. (Do not click OK).
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5. Select the “Background” category, and  

click the Browse button to navigate to back-

ground image we want to use.

6. Navigate to Slices folder you downloaded, 

select bg_body.jpg image and press OK.
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7. Read the warning and press YES.

8. Dreamweaver will take you to your site root 

folder (Dreambig).  Click the New Folder 

icon. This will create a new folder and high-

light the folder name, making it ready for you to 

rename it.  Rename the new folder to “im-

ages” (all lowercase)

new folder icon
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9. Double-click the images folder 

to select it.

10. Click the Save button to save bg_body 

inside the images folder.
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11. Set Background properties to reflect the 

screen-shot on the right.

12. Click the Box category and specify box 

properties to reflect the screen-shot below.

13. Press OK button.

And you are done creating a new CSS file and 

attaching it to the index.html document. At this 

point you should save all your pages.

Go to File->Save All
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Create a XHTML/CSS layout
In this section we will create our XHTML markup as well as CSS. 

#header

#wrapper

#navigation

#promo

#content #sidebar

#footer

Take a look at the illustration of the wireframe 

and note that we will be inserting our layout  

elements in following order:

#wrapper	 - At insertion point

#header	 - After start of tag #wrapper

#navigation	 - After tag #header

#promo	 - After tag #navigation

#content 	 - After tag #promo

#sidebar	 - After tag #content

#footer 	 - After tag #sidebar

All of this will start making more sense after we 

start inserting tags. As we insert tags we will 

define CSS properties and values for each one  

of them. 
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1. Click the Insert Div Tag button under the 

Common tab.

2. From the Insert menu select At insertion 

point. Type “wrapper” (all lowercase) inside 

the ID field and press New CSS Rule button.

3. In the New CSS Rule window make sure  

Selector Type is set to ID, Selector Name to 

#wrapper and Rule Definition to 

css_styles.css and press OK.

Add #wrapper
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4. Select Background from the Category menu

5. Press the Browse button.

6. Press the Site Root button to navigate to 

your sites folder. 

7. Double-click the images folder 

8. Select bg_body.jpg file from the list 

9. Press OK

10. Set other background properties as shown in 

the image. (Do not click OK when done)

11. Select Box category and set Box properties as 

shown in the image. 

NOTE: Setting margin to 0px, auto, 0px, 

auto centers the box on the page.

12. Press OK
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13. Press OK

14. Wrapper div is now added to your document.

Add #header
1. Click the Insert Div Tag button under the 

Common tab.

2. From the Insert menu select After start of 

tag, and select <div id=“wrapper”> from the 

second select box. Type in “header” (all 

lowercase) inside the ID field and press New 

CSS Rule button.

3. In the New CSS Rule window make sure  

Selector Type is set to ID, Selector Name to 

#header and Rule Definition to 

css_styles.css and press OK.
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4. Select Box category and set Box properties as 

shown in the image. 

5. Press OK

6. Press OK

7. Header div is now added to your document.

Add #navigation
1. Click the Insert Div Tag button under the 

Common tab.

2. From the Insert menu select After tag, and 

select <div id=“header”> from the second 

select box. Type in “navigation” (all 

lowercase) inside the ID field and press New 

CSS Rule button.
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3. In the New CSS Rule window make sure  

Selector Type is set to ID, Selector Name to 

#navigation and Rule Definition to 

css_styles.css and press OK.

3. Select Background from the Category menu

4. Press the Browse button.

5. Navigate to Slices folder you downloaded, 

select bg_navigation.jpg image

6. Press OK.
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7. Read the warning and press YES.

8. Click the Save button to save 

bg_navigation inside the images folder.

9. Set Background properties to reflect the 

screen-shot on the right. (Do not press OK 

when done)



Dreamweaver CS4 Quick Visual Guide:  LAYOUT						    

10. Select Box category and set Box properties 

as shown in the image.  (Do not press OK 

when done)

11. Select Border category and set Border 

properties as shown in the image. 

12. Press OK

13. Press OK

14. Navigation div is now added to  

your document.

Add #promo
1. Click the Insert Div Tag button under the 

Common tab.
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2. From the Insert menu select After tag, and 

select <div id=“navigation”> from the second 

select box. Type in “promo” (all lowercase) 

inside the ID field and press New CSS Rule 

button.

3. In the New CSS Rule window make sure  

Selector Type is set to ID, Selector Name to 

#promo and Rule Definition to 

css_styles.css and press OK.

4. Select Background from the Category menu

5. Press the Browse button.
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6. Navigate to Slices folder you downloaded, 

select bg_promo_image.jpg image and note 

the height of the image “257”. We will use this 

number when we specify the height of the promo 

element later.

7. Press OK.

8. Read the warning and press YES.
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9. Click the Save button to save 

bg_promo_image inside the 

images folder.

10. Set Background properties to reflect the 

screen-shot on the right. (Do not press OK 

when done)

11. Select Box category and set Box properties as 

shown in the image.  

12. Press OK

13. Press OK

14. Promo div is now added to your document.
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Add #content
1. Click the Insert Div Tag button under the 

Common tab.

2. From the Insert menu select After tag, and 

select <div id=“promo”> from the second 

select box. Type in “content” (all lowercase) 

inside the ID field and press New CSS Rule 

button.

3. In the New CSS Rule window make sure  

Selector Type is set to ID, Selector Name to 

#content and Rule Definition to 

css_styles.css and press OK.
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4. Select Box category and set Box properties as 

shown in the image. 

5. Press OK

6. Press OK

7. Content div is now added to your document.

Add #sidebar
1. Click the Insert Div Tag button under the 

Common tab.

2. From the Insert menu select After tag, and 

select <div id=“content”> from the second 

select box. Type in “sidebar” (all lowercase) 

inside the ID field and press New CSS Rule 

button.



Dreamweaver CS4 Quick Visual Guide:  LAYOUT						    

4. Select Box category and set Box properties as 

shown in the image. (Do not press OK when 

done)

5. Select Border category and set Border 

properties as shown in the image. 

6. Press OK

3. In the New CSS Rule window make sure  

Selector Type is set to ID, Selector Name to 

#sidebar and Rule Definition to 

css_styles.css and press OK.
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7. Press OK

8. Sidebar div is now added to your document.

Add #footer
1. Click the Insert Div Tag button under the 

Common tab.

2. From the Insert menu select After tag, and 

select <div id=“sidebar”> from the second 

select box. Type in “sidebar” (all lowercase) 

inside the ID field and press New CSS Rule 

button.

3. Set Background properties to reflect the 

screen-shot on the right. (Do not press OK 

when done)
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5. Select Border category and set Border 

properties as shown in the image. 

6. Press OK

4. Select Box category and set Box properties as 

shown in the image.  (Do not press OK when 

done)

7. Press OK

8. Footer div is now added to your document.

All layout elements are now inserted in our 

document. 

Go to File->Save All
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Little clean up
Locate the text “Content for “wrapper” div goes 

here and highlight it. 

NOTE: Make sure to not drag your mouse too 

far as you could accidently select and delete 

“footer” div.

Once highlighted press “Delete” or “Backspace” 

key on your keyboard.

You are done!


